Project

General

Profile

Bug #5559

IE 11 display issues related to table padding/margins

Added by Steve Beaver over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
12/01/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Associated revisions

Revision fdb83ce0 (diff)
Added by NOYB NOYB over 3 years ago

Firewall / Rules - Page Efficiency Upgrade

1) Only load the rules of the selected interface instead of loading all the rules of all interfaces and hiding them. Very inefficient and can result in sluggishness. Especially with large number of rules and/or large alias tables.

1.1) Rule separators indexed to their position within their interface so they work with only loading the selected interface rules.

2) Supports consecutive separators.

3) Fixes #5559 - horizontal scrollbar when no rules to display (all hidden). No longer hiding rules.

4) Corrects case where a single rule defined on any interface would prevent the alert messages from being displayed on all interfaces.

History

#1 Updated by Steve Beaver over 3 years ago

Jarred,

I thought this might be better for you to look at. You have easier access to IE11 than me :)

Probably start by removing the "table-condensed" class and see if that helps?

#2 Updated by NOYB NOYB over 3 years ago

The cause of horizontal scrollbar on interfaces without any rules is that all rows of the table (rules of other interfaces) are hidden.

If any rows exist in the table and all the rows are hidden then there is an overflow resulting in horizontal scrollbar.

When there are no rows in the table (inclusive of no hidden rows) then a row is added automatically in the DOM.

#3 Updated by NOYB NOYB over 3 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#4 Updated by Steve Beaver over 3 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF