Project

General

Profile

Bug #5623

DHCP text options are being encoded before storage which leads to a problem with certain characters

Added by Jim Pingle about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
DHCP Server
Target version:
Start date:
12/10/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

With a DHCP numbered option set for "text" if a value is stored that contains a character such as "&" it is changed to "&" and written into the DHCP config with "&" rather than "&" as intended.

Associated revisions

Revision 65cce9d7 (diff)
Added by Renato Botelho almost 4 years ago

Encode DHCP/DHCPv6 server additional BOOTP text options before save to XML to preserve data. It fixes #5623

History

#1 Updated by Jim Pingle about 4 years ago

  • Description updated (diff)

#2 Updated by Jim Thompson almost 4 years ago

  • Assignee set to Renato Botelho

#3 Updated by Renato Botelho almost 4 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#4 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Resolved

works

Also available in: Atom PDF