Project

General

Profile

Actions

Bug #5841

closed

firewall_rules_edit.php - Floating rules added to the top of the rules list produce XML error

Added by Steve Beaver over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Very High
Assignee:
Category:
Web Interface
Target version:
Start date:
02/04/2016
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3
Affected Architecture:

Description

firewall_rules.php - visit the "Floating" tab, click hte "Add to top" button add a description and save. The system produces an XML error.

Actions #1

Updated by Steve Beaver over 5 years ago

  • Status changed from Confirmed to Feedback

Interface name is set to "FloatingRules" which conflicted with the XML due to case insensitivity.

Added some strtolower() where required to normalize the name.

Actions #2

Updated by Steve Beaver over 5 years ago

  • % Done changed from 0 to 100
Actions #3

Updated by Steve Beaver over 5 years ago

  • Subject changed from firewall_rules_edit.php - Floating rules added to the top of hte rules list produce XML error to firewall_rules_edit.php - Floating rules added to the top of the rules list produce XML error
  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF