Project

General

Profile

Bug #6013

Renaming a group doesn't rename or update it in group file

Added by Chris Buechler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
User manager
Target version:
Start date:
03/19/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

Renaming a group in the user manager leaves the former group name in /etc/group. groupmod -l $group_name should fix.

Associated revisions

Revision 7cb01159 (diff)
Added by Chris Buechler over 3 years ago

Check whether group exists using GID rather than name. Users can change the name, but not the GID. Check return code of pw for whether group exists. Ticket #6013

History

#1 Updated by Chris Buechler over 3 years ago

  • Subject changed from Renaming a group doesn't rename it in group file to Renaming a group doesn't rename or update it in group file
  • Status changed from Confirmed to Feedback
  • Assignee set to Chris Buechler

also never updated it because it used groupadd instead of groupmod.

fixed

#2 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF