Project

General

Profile

Bug #6030

Duplicated tracker IDs on block private networks rules

Added by NOYB NOYB about 5 years ago. Updated 3 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Rules / NAT
Target version:
Start date:
03/26/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:
Release Notes:
Default

Description

Mar 26 15:16:27 WAN Block ULA networks from WAN block fc00::/7 (12000) 192.168.2.21 192.168.2.42 ICMP

Shouldn't it log the IPv4 block message.

Can edit filter.inc and change the order and it logs the last one of the list.

Associated revisions

Revision 1574802c (diff)
Added by Renato Botelho 6 months ago

Fix #6030

Use a range of tracker ids for anti-lockout, bogons and rfc1918 rules so
any rule has a unique identifier

History

#1 Updated by Chris Buechler about 5 years ago

  • Subject changed from Block Private Networks Logging Wrong Block Description to Duplicated tracker IDs on block private networks rules
  • Category set to Rules / NAT
  • Status changed from New to Confirmed
  • Assignee set to Chris Buechler
  • Affected Version set to 2.3

they no longer have unique tracker IDs as they should and used to.

#2 Updated by Jim Thompson about 5 years ago

  • Assignee changed from Chris Buechler to Steve Beaver

#3 Updated by Chris Buechler about 5 years ago

  • Priority changed from Normal to Low
  • Target version changed from 2.3 to 2.3.1

regressed in cc2cff0b, because of the counters shown on firewall_rules.php rely on those being static. Not a big deal.

#4 Updated by Chris Buechler almost 5 years ago

  • Target version changed from 2.3.1 to 2.3.2

#5 Updated by Chris Buechler almost 5 years ago

  • Target version changed from 2.3.2 to 2.4.0

#6 Updated by Steve Beaver over 4 years ago

  • Assignee changed from Steve Beaver to Luiz Souza

#7 Updated by Luiz Souza over 3 years ago

  • Target version changed from 2.4.0 to 2.4.1

#8 Updated by Jim Pingle over 3 years ago

  • Target version changed from 2.4.1 to 2.4.2

#9 Updated by Jim Pingle over 3 years ago

  • Target version changed from 2.4.2 to 2.4.3

#10 Updated by Luiz Souza about 3 years ago

  • Target version changed from 2.4.3 to 2.4.4

#11 Updated by Luiz Souza over 2 years ago

  • Target version changed from 2.4.4 to 48

#12 Updated by Jim Pingle about 2 years ago

  • Target version changed from 48 to 2.5.0

#13 Updated by Renato Botelho 6 months ago

  • Assignee changed from Luiz Souza to Renato Botelho

I'm working on a fix

#14 Updated by Renato Botelho 6 months ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#15 Updated by Steve Beaver 6 months ago

  • Assignee changed from Renato Botelho to NOYB NOYB

#16 Updated by Steve Beaver 6 months ago

Please confirm fix

#17 Updated by Michael Spears 3 months ago

Steve Beaver wrote:

Please confirm fix

Looks good from what I can tell.

#18 Updated by Jim Pingle 3 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF