Project

General

Profile

Bug #6101

Alias/NTP/uPNP/other Edit add and then delete of new rows issue

Added by Phillip Davis almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
04/09/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

Case 1:
a) Edit an existing Alias with n entries - rows 1 to n are displayed, good.
b) Press the Add button, enter data into 1 or more new rows.
c) Decide that you do not want one of those new rows - press its Delete button.
Expected result: The new row disappears.
Actual result: Row n disappears (the last of the original rows)

Case 2:
a) Add a new Alias - row 1 is displayed with no data in it, good.
b) Enter data into row 1
c) Press the Add button, enter data into 1 or more new rows.
d) Decide that you do not want one of those new rows - press its Delete button.
Expected result: The new row disappears.
Actual result: Row 1 disappears

This is "disconcerting" for users, and results in unintended data loss/modification if users are doing add/delete of rows as they decide what they really want in the alias.

Reported in forum: https://forum.pfsense.org/index.php?topic=109554.0

History

#1 Updated by Chris Buechler almost 3 years ago

  • Status changed from New to Confirmed

#2 Updated by Jim Thompson almost 3 years ago

  • Assignee set to Steve Beaver

#3 Updated by Phillip Davis almost 3 years ago

It is fixed by https://github.com/pfsense/pfsense/pull/2854
But Steve or someone should look to see if there are any other side-effects of the fix, because it is in the common JS code. Maybe it will fix a similar problem in other place also that have multi-row entry with real-time interactive add-delete of rows.

#4 Updated by Jim Thompson almost 3 years ago

Thanks, Phil.

#5 Updated by Steve Beaver almost 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

Phil's patch has been tested and applied. Thanks!

#6 Updated by Evan Susarret almost 3 years ago

It may be worth noting that this affects other pages as well - I discovered it on the UPnP settings page.
I considered opening a separate bug for the issue, but according to the note above the issue has already been addressed. Thanks, Phil!

#7 Updated by Steve Beaver almost 3 years ago

The fix will apply to all pages that use this construct, including UPnP.

#8 Updated by Chris Buechler almost 3 years ago

  • Status changed from Feedback to Resolved

works

#9 Updated by Chris Buechler almost 3 years ago

  • Subject changed from Alias Edit add and then delete of new rows issue to Alias/NTP/uPNP/other Edit add and then delete of new rows issue

Also available in: Atom PDF