Project

General

Profile

Bug #6149

Proxy settings from system_advanced_misc.php are not respected by pkg

Added by Jim Pingle about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Operating System
Target version:
Start date:
04/14/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

The proxy settings entered on system_advanced_misc.php are not respected by pkg, at least when using pkg from the GUI.

The proxy parameters may need to be placed directly into the pkg repo config file if setting them in the environment does not function as expected.

Needs tested from a shell prompt also. Currently the http_proxy/HTTP_PROXY environment variables are set but whether those are respected by pkg as well needs to be confirmed.

pkg-proxy.diff (1.35 KB) pkg-proxy.diff Jim Pingle, 04/19/2016 02:09 PM

History

#2 Updated by Jim Pingle about 3 years ago

  • File pkg-proxy.diff added

Potential patch attached. Works for me here in a test setup, but needs some verification.

#3 Updated by Jim Pingle about 3 years ago

Better version of the patch after feedback from Renato

#4 Updated by Jim Pingle about 3 years ago

  • File deleted (pkg-proxy.diff)

#5 Updated by Jim Pingle about 3 years ago

  • Status changed from New to Feedback
  • Assignee changed from Renato Botelho to Jim Pingle

I pushed the last patch, commit:cb661db and commit:2bde5fb

#6 Updated by Chris Buechler about 3 years ago

  • Status changed from Feedback to Resolved

this works both in GUI and CLI.

#7 Updated by Glenn Provoost about 3 years ago

this patched worked for me, but only after changing the uppercase HTTP_PROXY to lowercase http_proxy

Also available in: Atom PDF