Project

General

Profile

Bug #6168

load_balancer_pool.php and load_balancer_virtual_server.php: Can't copy Load Balancer pool or virtual server

Added by Marcin Janczarski about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
04/15/2016
Due date:
% Done:

100%

Affected Version:
2.3
Affected Architecture:

Description

When I want to copy a pool in LB tab it's editing object that was taken as a source of copy and not create new one.

Associated revisions

Revision 91cd1923
Added by Steve Beaver about 2 years ago

Fixed #6168
Needed to override form action since it was inheriting the current GET arguments

Revision 994895f3
Added by Steve Beaver about 2 years ago

Fixed #6168
Needed to override form action since it was inheriting the current GET arguments

(cherry picked from commit 91cd1923b133c57eaa9897ce4574ce19b7122dc4)

History

#1 Updated by Chris Buechler about 2 years ago

  • Subject changed from GUI Can't copy Load Balancer pool to GUI Can't copy Load Balancer pool or virtual server
  • Category set to Web Interface
  • Status changed from New to Confirmed
  • Target version set to 2.3.1
  • Affected Version set to 2.3

also true of virtual server.

#2 Updated by Steve Beaver about 2 years ago

  • Subject changed from GUI Can't copy Load Balancer pool or virtual server to load_balancer_pool.php and load_balancer_virtual_server.php: Can't copy Load Balancer pool or virtual server

#3 Updated by Steve Beaver about 2 years ago

  • Status changed from Confirmed to Feedback
  • Assignee set to Marcin Janczarski

If the form action is not explicitly specified, it uses the current GET arguments which broke the "dup" functionality.

form action is now specified.

Another reason to get rid of GET

#4 Updated by Steve Beaver about 2 years ago

  • % Done changed from 0 to 100

#5 Updated by Chris Buechler about 2 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF