Project

General

Profile

Bug #6287

firewall_nat_out_edit.php: Destination (Type: Network) field auto-complete does not show aliases with networks

Added by Dmitriy K almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Rules/NAT
Target version:
Start date:
04/29/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:
All

Description

The "Source" field auto-complete works as expected, but "Destination" is not.

Current Base System: 2.3.1.a.20160426.0539

capture-4.mp4 (666 KB) capture-4.mp4 Dmitriy K, 04/29/2016 04:06 AM

Associated revisions

Revision 99ace4fc (diff)
Added by Steve Beaver almost 3 years ago

Fixed #6287

(cherry picked from commit 2342972531265771e65b69b810de0c9d98c69b94)

History

#1 Updated by Chris Buechler almost 3 years ago

  • Status changed from New to Confirmed

#2 Updated by Steve Beaver almost 3 years ago

  • Assignee set to Steve Beaver

Looks like it is actually using port aliases instead of addresses. Looking at it now.

#3 Updated by Steve Beaver almost 3 years ago

  • Subject changed from NAT - Outbound - Destination (Type: Network) field auto-complete does not show aliases with networks to firewall_nat_out_edit.php: Destination (Type: Network) field auto-complete does not show aliases with networks

#4 Updated by Steve Beaver almost 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Dmitriy K

Autocomplete needed to be re-applied to the element after each enable/disable action

#5 Updated by Steve Beaver almost 3 years ago

  • % Done changed from 0 to 100

#6 Updated by Dmitriy K almost 3 years ago

2.3.1.a.20160502.0743: Fixed.

#7 Updated by Steve Beaver almost 3 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF