Project

General

Profile

Bug #6317

vlan/track interface generates error "Can't assign requested address" during boot

Added by Paul K over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Low
Category:
Interfaces
Target version:
Start date:
05/05/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3.x
Affected Architecture:
All

Description

I have LAN interface that is a vlan and is configured to track my WAN interface. After upgrading to 2.3 I started seeing following error message during boot:

rc.bootup: The command '/sbin/ifconfig vmx1_vlan10 inet6 fe80::20c:29ff:1234:1234%vmx1_vlan10 delete' returned exit code '1', the output was 'ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address' 

Turns out function interface_track6_configure(), that replaces MAC based LL address with fe80::1:1, gets called twice for each vlan/tracking interface during boot. Second time it is called it uses stale LL address and tries to remove IP address that does not exist.

"Call stack" of the 2 calls:

interfaces_configure -> interfaces_vlan_configure -> interface_vlan_configure -> interface_configure -> interface_track6_configure
interfaces_configure -> interface_configure -> interface_track6_configure

History

#2 Updated by Chris Buechler over 3 years ago

  • Status changed from New to Confirmed
  • Target version set to 2.3.2

#3 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee set to Chris Buechler
  • Affected Version changed from 2.3 to 2.3.x

PR confirmed and merged

#4 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

works

Also available in: Atom PDF