Project

General

Profile

Todo #6443

Add ntopng package back into pfSense 2.3.x

Added by Andrew - about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
ntop
Target version:
-
Start date:
06/03/2016
Due date:
% Done:

0%

Estimated time:

Description

The ntopng package was previously removed from pfSense 2.3.x because the ntopng port didn't build in FreeBSD.

pfSense has now been added back into the FreeBSD-ports tree, and has been re-added back into the pfSense custom ports tree (see here: https://github.com/pfsense/FreeBSD-ports/tree/devel/net/ntopng)

The ntopng package itself also appears to be in the packages tree: https://github.com/pfsense/pfsense-packages/tree/master/config/ntopng

The ntopng package itself remains unavailable though in the packages list in pfSense.

Please can it be restored.

History

#1 Updated by Andrew - about 3 years ago

"*pfSense* has now been added back into the FreeBSD-ports tree" ... sorry, meant ntopng obviously.

#2 Updated by jeroen van breedam about 3 years ago

pfsense-packages repo on github is no longer in use (it was used before 2.3 )
New packages go straight into the FreeBSD-ports repo with naming scheme pfSense-pkg-<package_name>

#4 Updated by Renato Botelho about 3 years ago

  • Status changed from New to Feedback

I've added it back to 2.3.2 snapshots, that can be downloaded at https://snapshots.pfsense.org

Note that it was not tested yet

#5 Updated by Andrew - about 3 years ago

Hi Renato. Many thanks for adding it back. I suspect the answer may be no, but is there any way to run the package (at my own risk) on a release version of 2.3.1 please? Then I can run a beta version of just ntopng, rather than an entire pfSense build. I'm quite keen to test it.

#6 Updated by Rich Murphey about 3 years ago

I've installed snapshot 2.3.2.a.20160606.1543, and ntopng via the web UI package manager.

I see only one possible issue.
After setting the password via the ntopng settings page in the pfsense UI, the ntopng admin password is not updated.
That is, after setting it, I was only able to login to the ntopng web interface using the default user=admin and password=admin combination.

One can change the password in the ntopng web UI, so there's no loss of functionality I can see presently.

#7 Updated by Michael Kellogg about 3 years ago

install fails on 2.3.2a here is log
\>>> Installing pfSense-pkg-ntopng...
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
The following 19 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
pfSense-pkg-ntopng: 0.8.3_2 [pfSense]
webfonts: 0.30_10 [pfSense]
mkfontdir: 1.0.7 [pfSense]
mkfontscale: 1.1.2 [pfSense]
xproto: 7.0.28 [pfSense]
freetype2: 2.6.3 [pfSense]
libfontenc: 1.1.3 [pfSense]
fontconfig: 2.11.1_1,1 [pfSense]
ntopng: 2.2.2016.05.28 [pfSense]
ndpi: 1.8 [pfSense]
json-c: 0.12_2 [pfSense]
graphviz: 2.38.0_12 [pfSense]
libgd: 2.1.0_7,1 [pfSense]
png: 1.6.21 [pfSense]
jpeg-turbo: 1.4.2 [pfSense]
tiff: 4.0.6_1 [pfSense]
jbigkit: 2.1_1 [pfSense]
redis: 3.0.7 [pfSense]
gdbm: 1.11_2 [pfSense]

The process will require 89 MiB more space.
9 MiB to be downloaded.
Fetching pfSense-pkg-ntopng-0.8.3_2.txz: . done
Fetching webfonts-0.30_10.txz: .......... done
Fetching mkfontdir-1.0.7.txz: . done
Fetching mkfontscale-1.1.2.txz: .. done
Fetching xproto-7.0.28.txz: ...... done
Fetching freetype2-2.6.3.txz: .......... done
Fetching libfontenc-1.1.3.txz: .. done
Fetching fontconfig-2.11.1_1,1.txz: .......... done
Fetching ntopng-2.2.2016.05.28.txz: .......... done
Fetching ndpi-1.8.txz: .......... done
Fetching json-c-0.12_2.txz: .... done
Fetching graphviz-2.38.0_12.txz: .......... done
Fetching libgd-2.1.0_7,1.txz: .......... done
Fetching png-1.6.21.txz: .......... done
Fetching jpeg-turbo-1.4.2.txz: .......... done
Fetching tiff-4.0.6_1.txz: .......... done
Fetching jbigkit-2.1_1.txz: ...... done
Fetching redis-3.0.7.txz: .......... done
Fetching gdbm-1.11_2.txz: .......... done
Checking integrity... done (0 conflicting)
[1/19] Installing xproto-7.0.28...
[1/19] Extracting xproto-7.0.28: .......... done
[2/19] Installing freetype2-2.6.3...
[2/19] Extracting freetype2-2.6.3: .......... done
[3/19] Installing libfontenc-1.1.3...
[3/19] Extracting libfontenc-1.1.3: ...... done
[4/19] Installing jpeg-turbo-1.4.2...
[4/19] Extracting jpeg-turbo-1.4.2: .......... done
[5/19] Installing jbigkit-2.1_1...
[5/19] Extracting jbigkit-2.1_1: .......... done
[6/19] Installing mkfontscale-1.1.2...
[6/19] Extracting mkfontscale-1.1.2: .. done
[7/19] Installing json-c-0.12_2...
[7/19] Extracting json-c-0.12_2: .......... done
[8/19] Installing png-1.6.21...
[8/19] Extracting png-1.6.21: .......... done
[9/19] Installing tiff-4.0.6_1...
[9/19] Extracting tiff-4.0.6_1: .......... done
[10/19] Installing mkfontdir-1.0.7...
[10/19] Extracting mkfontdir-1.0.7: .. done
[11/19] Installing fontconfig-2.11.1_1,1...
[11/19] Extracting fontconfig-2.11.1_1,1: .......... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: skipping, no such directory
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
[12/19] Installing ndpi-1.8...
[12/19] Extracting ndpi-1.8: .......... done
[13/19] Installing libgd-2.1.0_7,1...
[13/19] Extracting libgd-2.1.0_7,1: .......... done
[14/19] Installing webfonts-0.30_10...
[14/19] Extracting webfonts-0.30_10: .......... done
[15/19] Installing ntopng-2.2.2016.05.28...
===> Creating users and/or groups.
Creating group 'ntopng' with gid '288'.
Creating user 'ntopng' with uid '288'.
[15/19] Extracting ntopng-2.2.2016.05.28: .....
pkg: archive_read_extract() errno 2: Can't create '/usr/local/share/ntopng/scripts/callbacks/daily.lua'
[15/19] Extracting ntopng-2.2.2016.05.28... done
[15/19] Deleting files for ntopng-2.2.2016.05.28: .......... done
Failed

#8 Updated by Kill Bill about 3 years ago

Rich Murphey wrote:

After setting the password via the ntopng settings page in the pfsense UI, the ntopng admin password is not updated.

Every case of this I've seen on the 2.2.x ntopng package was a password manager (either built-in, or third-party one, like LastPass) screwing up, saving a different password than what you actually typed in.

#9 Updated by Phil Freeman about 3 years ago

Kill Bill wrote:

Rich Murphey wrote:
Every case of this I've seen on the 2.2.x ntopng package was a password manager (either built-in, or third-party one, like LastPass) screwing up, saving a different password than what you actually typed in.

I can confirm the behavior of the previous poster with pfSense 2.3.2 and ntopng. The password settings in the pfSense gui don't have any effect on the ntopng credentials. You must set the password via the ntopng interface.

#10 Updated by Michael Kellogg about 3 years ago

deleted

/usr/local/share/ntopng

that fixed install

#11 Updated by Andrew - about 3 years ago

Thanks for working on this, It's good to have ntopng back.

I didn't have any install issues (though it looks from the above that the reason for that has been identified anyway).

The main issue I've experienced so far is that ntopng doesn't restart on reboot. The only way to get the service to restart then is to reinstall the package.

That said, I had the same issue on pfSense 2.2.x. see here: https://forum.pfsense.org/index.php?topic=103330.0

I haven't checked if the log messages are the same in 2.3.x. Will do so when I get a moment.

#12 Updated by Rich Murphey about 3 years ago

There is a missing dependency on GeoIP-1.6.9.

I tried to restart the service, which failed.
Then logged in and tried to start it from the command line, as follows.
/usr/local/etc/rc.d/ntopng.sh start
[2.3.2-DEVELOPMENT][]/root: Shared object "libGeoIP.so.1" not found, required by "ntopng"

find / -name '*GeoIP*' showed nothing.
It was resolved by:
pkg install GeoIP-1.6.9
/usr/local/bin/geoipupdate.sh
/usr/local/etc/rc.d/ntopng.sh start
which successfully started ntopng.

#13 Updated by Rich Murphey about 3 years ago

I submitted a pull request to add GeoIP as a dependency of ntopng:

https://github.com/pfsense/FreeBSD-ports/pull/148

#14 Updated by Jim Thompson about 3 years ago

  • Status changed from Feedback to Assigned
  • Assignee set to Renato Botelho
  • Priority changed from High to Normal

#15 Updated by Andrew - about 3 years ago

I'm still having the issue with ntopng not restarting after a reboot, with the following errors in the log.

Jul 13 00:55:23 ntopng [Redis.cpp:81] ERROR: to specify a redis server other than the default
Jul 13 00:55:23 ntopng [Redis.cpp:80] ERROR: Please start it and try again or use -r
Jul 13 00:55:23 ntopng [Redis.cpp:79] ERROR: ntopng requires redis server to be up and running

Having done some more digging, I think it might be due to the fact that I'm using RAM disks for tmp and var.

The redis server has a temp directory in /var/db/redis which will get lost on a reboot.

There's a puil request here to treat the RAM disks more as permanent storage - https://github.com/pfsense/pfsense/pull/2902

If the purpose of that is to store and then restore the content of the tmp/var directories on a reboot, then that should sort this issue out.

#16 Updated by Jim Pingle about 3 years ago

Rich Murphey wrote:

I've installed snapshot 2.3.2.a.20160606.1543, and ntopng via the web UI package manager.

I see only one possible issue.
After setting the password via the ntopng settings page in the pfsense UI, the ntopng admin password is not updated.
That is, after setting it, I was only able to login to the ntopng web interface using the default user=admin and password=admin combination.

One can change the password in the ntopng web UI, so there's no loss of functionality I can see presently.

I just pushed a fix for this. The password is set OK now.

#17 Updated by Jared Dillard almost 3 years ago

  • Status changed from Assigned to Resolved

ntopng will be in the pfSense 2.3.2 release. New tickets should be opened if there are issues with the package upon release.

Also available in: Atom PDF