Project

General

Profile

Bug #6495

No default route on PPPoE after reconnect or IP change in some cases

Added by Mario Lener about 1 year ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Routing
Target version:
Start date:
06/17/2016
Due date:
% Done:

0%

Affected version:
2.3.x
Affected Architecture:
All

Description

Hi, i found a strange error from release 2.3 on default route on PPPoE interface. I write a post with print screen in pfSense forum: https://forum.pfsense.org/index.php?topic=113750.0

At first I thought was a PPPoE problem related, but after some test i realize that with PPPoE when there is a link failure or a ip change from ISP the default route 0.0.0.0/0 was never set up again. I need to recreate manually, running command route add -net 0.0.0.0/0 -interface pppoe1. After this command, everything works perfectly. It is a serious problem, since my ISP assigns dynamic IP that change often.
I tried both x64 and NanoBSD (Alix), Same problem until last 2.3.1_5. With 2.2.6 default route works without problem.

Thanks in advance for your support and your fantastic firewall. :-)

--
Mario Lener

Associated revisions

Revision 258f1f11
Added by Chris Buechler 11 months ago

Bring back the "set iface route default" used in 2.2.6 and earlier versions, which works around the root problem in Ticket #6495

Revision 5bd2dd83
Added by Chris Buechler 11 months ago

Bring back the "set iface route default" used in 2.2.6 and earlier versions, which works around the root problem in Ticket #6495

History

#1 Updated by Mario Lener about 1 year ago

Mario Lener wrote:

Hi, i found a strange error from release 2.3 on default route on PPPoE interface. I write a post with print screen in pfSense forum: https://forum.pfsense.org/index.php?topic=113750.0

At first I thought was a PPPoE problem related, but after some test i realize that with PPPoE when there is a link failure or a ip change from ISP the default route 0.0.0.0/0 was never set up again. I need to recreate manually, running command route add -net 0.0.0.0/0 -interface pppoe1. After this command, everything works perfectly. It is a serious problem, since my ISP assigns dynamic IP that change often.
I tried both x64 and NanoBSD (Alix), Same problem until last 2.3.1_5. With 2.2.6 default route works without problem.

Thanks in advance for your support and your fantastic firewall. :-)

--
Mario Lener

EDIT: i make a modify in /etc/inc/interfaces.inc and reactivate this code:

_/* Omit this, we maintain the default route by other means, and it causes problems with * default gateway switching. See redmine #1837 */
if (($interface "wan" && $founddefaultgw false) || $setdefaultgw == true) {
$setdefaultgw = true;
$mpdconf .= <<<EOD
set iface route default

EOD;
}_

I know that it was REMed for bug #1837, but in this way PPPoE connection works without problem after link failure, cable disconnection or IP change.

#2 Updated by Chris Buechler about 1 year ago

  • Status changed from New to Feedback

followed up in your forum thread.

#3 Updated by Mario Lener about 1 year ago

Hi Chris,

followed up in your forum thread.

In the past weekend i made more test with different ISP: i live in Italy, so i tried pfSense 2.2.6 and 2.3.1 on my home pfSense (x64 Atom 1.8 dual core) and Alix 2d3. Some friends of mine have other PPPoE and PPPoA ISP, so i can made different test. With PPPoA, i use a Draytec converting PPPoA -> PPPoE.
In All conditions, I encountered the same error: sometimes (only sometimes) at FIRST boot PPPoE goes UP, but as soon as the IP from ISP is changed or PPPoE goes down, or cable is disconnected, it's not resumed and stay down. With code modifyied, all works without problems.
This is all test i can do, in my office i have 14 pfSense but all with WAN static IP.

Do you think it would be possible to modify the code as I said in the post of the thread that I opened (if ONE GW then <Code> else (TWO or MORE GW) <Code> endif)?

Thanks in advance for your support.

EDIT: i modify the object of the thread i opened, adding a request for testing the fix.

--
Mario

#4 Updated by Chris Buechler about 1 year ago

  • Subject changed from [2.3.x] No default route on WAN PPPoE after link failure or IP change to No default route on PPPoE after reconnect or IP change in some cases
  • Category set to Routing
  • Status changed from Feedback to Confirmed
  • Assignee set to Chris Buechler
  • Target version set to 2.3.1_6
  • Affected version set to 2.3.x

I'm not sure what circumstance triggers this, but judging by the number of reports in that thread there is something. The proposed fix isn't right. I can't replicate any issues, whether just forcing an IP change, losing link on the WAN NIC, or losing connectivity to the PPPoE server without losing link. All recover as they should, rc.newwanip sets the default gateway correctly every time.

Posted in that thread to get more specifics from anyone seeing it.

#5 Updated by Michael Knowles about 1 year ago

Hi,

I'm the author of Bug #6423. This bug sounds remarkably similar to my symptoms.

I'm going to get the onsite presence to restart the router and then make this edit and see whether my connection will finally stay up for more than a day. Will report back.

Mike.

#6 Updated by Michael Knowles about 1 year ago

p.s. - The ADSL i'm using in this instance has a "static IP" delivered from the ISP via DHCP (or whatever mechanism it is for DHCP over PPP).

#7 Updated by Mario Lener about 1 year ago

Michael Knowles wrote:

p.s. - The ADSL i'm using in this instance has a "static IP" delivered from the ISP via DHCP (or whatever mechanism it is for DHCP over PPP).

I think you mean "dynamic IP", if your ISP use DHCP to assign your public IP. If it is, could be the same issue.

#8 Updated by Michael Knowles about 1 year ago

Yep, it's static in as much as it's supposed not to alter, and is the way that most "static IP" addresses are dished out over broadband in the UK - with the router set to obtain it via DHCP.

#9 Updated by Mario Lener about 1 year ago

Hi Chris,

I'm not sure what circumstance triggers this, but judging by the number of reports in that thread there is something. The proposed fix isn't right. I can't replicate any issues, whether just forcing an IP change, losing link on the WAN NIC, or losing connectivity to the PPPoE server without losing link. All recover as they should, rc.newwanip sets the default gateway correctly every time.

I post my system log in open thread, look at line 71/72. It is from my home firewall (2 gigabit, 64 bit, 4 Gb RAM, Atom 1.8 dual core). Ask me if you need more information.

Thanks in advance,

--
Mario

#10 Updated by Michael Knowles about 1 year ago

Just to let you know, unfortunately this hasn't solved my issue, and the line is dead again.

#11 Updated by Dmitriy K about 1 year ago

Same here. After reconnect (PPPoE) there was no default route set.

#12 Updated by Mario Lener 12 months ago

Hi Chris,

I'm not sure what circumstance triggers this, but judging by the number of reports in that thread there is something. The proposed fix isn't right. I can't replicate any issues, whether just forcing an IP change, losing link on the WAN NIC, or losing connectivity to the PPPoE server without losing link. All recover as they should, rc.newwanip sets the default gateway correctly every time.

New log in open thread. Hope it can help.

Thanks in advance,

--
Mario (Marlenio)

#13 Updated by Mario Lener 12 months ago

Hi Chris,
i post in open thread, but in my setup the file you ask isn't present.

--
Mario (Marlenio)

#14 Updated by Mario Lener 12 months ago

Hi Chris,
new update in thread-

--
Mario (Marlenio)

#15 Updated by Mario Lener 12 months ago

Hi Chris,
system log added. :)

Thanks,

Mario (Marlenio)

#16 Updated by Chris Buechler 12 months ago

  • Target version changed from 2.3.1_6 to 2.3.2

#17 Updated by Chris Buechler 11 months ago

  • Assignee deleted (Chris Buechler)
  • Target version changed from 2.3.2 to 2.4.0

I brought back the behavior of 2.2.6 and earlier here, as the root cause isn't readily apparent. The router file ends up empty (details in the linked forum thread with added debug logging).

This fixes subject issue for 2.3.2, though it breaks default gateway switching with PPP interfaces, that's a much less common circumstance.

Moving to 2.4 for a proper fix so that "set iface route default" can be removed from mpd's config again.

#18 Updated by Mario Lener 11 months ago

Hi Chris,

I brought back the behavior of 2.2.6 and earlier here, as the root cause isn't readily apparent. The router file ends up empty (details in the linked forum thread with added debug logging).

This fixes subject issue for 2.3.2, though it breaks default gateway switching with PPP interfaces, that's a much less common circumstance.

Moving to 2.4 for a proper fix so that "set iface route default" can be removed from mpd's config again.

Hi test your mod on snapshot 20160715.0559 and it's ok. Now PPP interfaces starts with correct default gateway.

Thanks in advance,

--
Marlenio

#19 Updated by Jim Pingle 7 months ago

  • Status changed from Confirmed to Resolved

Also available in: Atom PDF