Project

General

Profile

Bug #6551

Invalid IPv6 address can be entered

Added by Phillip Davis over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
06/28/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

For example, add a host alias, in the IP Address or FQDN box of the 1st entry put:
1:2:3:xy:4:5:6:7:8

This is accepted as a valid IPv6 address.

The problem is in the IPv6.inc routines.

History

#1 Updated by Phillip Davis over 3 years ago

Pull request https://github.com/pfsense/pfsense/pull/3026 has a proposed fix and longer explanation.

#2 Updated by Chris Buechler over 3 years ago

  • Status changed from New to Feedback

#3 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

This all looks good now. All the test cases that were wrong previously are correct now, and no apparent regressions.

#4 Updated by Chris Buechler over 3 years ago

  • Target version changed from 2.3.1-p6 to 2.3.2

Also available in: Atom PDF