Project

General

Profile

Bug #6707

diag_smart is broken

Added by Jeremy C. Reed 10 months ago. Updated 10 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
08/13/2016
Due date:
% Done:

0%

Affected version:
Affected Architecture:

Description

it appears the diag_smart is broken.
For example, its has
$start_script = "/usr/local/etc/rc.d/smartd.sh";

and it is used once for a stop and start. But that script
doesn't exist. It is at /usr/local/etc/rc.d/smartd (no ".sh" at end).

Anyways, I now see the code there is marked with //FIXME.

The smartd -M test is used to test configuration.

Also in diag_smart, it tries to put email address into
/usr/local/etc/smartd.conf but that file doesn't exist.
Then it does an attempted HUP of smartd but that daemon is not running.
Also the user interface is not intuitive. I'd suggest it
have options to enable the service,
and that the "Send test email" button should be available even
if email address is not saved; I didn't test but I think
can be done like:

echo /dev/sda -m foo@host -M test | smartd -c - -q onecheck

(By the way, it is interesting to have such a detailed
disk monitoring service, so it would be just as important
to have a network device and network in general monitoring service;
I understand sending email may not work, but it could check
for some "predictive" failures and send warning before network is down.)

(My list of bugs is at http://reedmedia.net/books/pfsense/bugs-20160813.html )

History

#1 Updated by Jim Pingle 10 months ago

  • Status changed from New to Duplicate

Duplicate of #6393

That page needs significant work.

Also available in: Atom PDF