Project

General

Profile

Bug #6730

dnsmasq - Ignoring query from non-local network

Added by Bart Heinsius almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DNS Forwarder
Target version:
Start date:
08/19/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3.2
Affected Architecture:

Description

Hi,

Last week i updated to 2.3.2-RELEASE (amd64) built on Wed Jul 20 10:29:55 CDT 2016 FreeBSD 10.3-RELEASE-p5

When i connect using openvpn, dns does not work anymore from the openvpn client.
From Status/System Logs/System/DNS Resolver:

Aug 18 23:07:18 dnsmasq 3814 Ignoring query from non-local network

In pfSense DNS Forwarder options i have Interfaces set to All.

Selecting all interfaces manually and deselecting All fixes the problem for me.

regards,
Bart H

Associated revisions

Revision a2a3ca38 (diff)
Added by Jim Pingle almost 3 years ago

Use "-C /dev/null" when starting dnsmasq to avoid it picking up an incorrect default config which would override our command line parameters. Fixes #6730

Revision a95e5334 (diff)
Added by Jim Pingle almost 3 years ago

Use "-C /dev/null" when starting dnsmasq to avoid it picking up an incorrect default config which would override our command line parameters. Fixes #6730

Revision 68ce71f2 (diff)
Added by Jim Pingle almost 3 years ago

Use "-C /dev/null" when starting dnsmasq to avoid it picking up an incorrect default config which would override our command line parameters. Fixes #6730

History

#1 Updated by Jim Pingle almost 3 years ago

  • Project changed from pfSense Packages to pfSense
  • Category changed from DNS Server to DNS Forwarder
  • Status changed from New to Confirmed
  • Target version set to 2.3.2-p1

Looks like this is due to /usr/local/etc/dnsmasq.conf being present. We don't use that or create it, but it is there and being read by dnsmasq and it contains an option causing this behavior ("local-service").

If you remove /usr/local/etc/dnsmasq.conf and restart dnsmasq it answers as expected. We're looking into it.

#2 Updated by Jim Pingle almost 3 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#3 Updated by Jim Pingle almost 3 years ago

  • Assignee set to Jim Pingle

#4 Updated by Jim Pingle almost 3 years ago

  • Status changed from Feedback to Resolved

Confirmed working from myself and others.

Also available in: Atom PDF