Project

General

Profile

Bug #6779

Traffic shaper wizard uses decimals instead of whole numbers

Added by Vladimir Putin about 1 year ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Traffic Shaper
Target version:
Start date:
09/09/2016
Due date:
% Done:

100%

Affected version:
All
Affected Architecture:

Description

After using traffic shaper wizard when you completed it you can get decimals in "Max bandwidth for queue" and other values also, that causes shaper to malfunction and ignore those queues or when you want to change something in queue settings this causes error messages in pfsense. The solution is to use WHOLE numbers instead of decimals.

Associated revisions

Revision 7c3a9ded
Added by Steve Beaver 11 months ago

Fixed #6779
Round calculated bandwidth down to nearest integer

Revision 16625f3c
Added by Steve Beaver 11 months ago

Fixed #6779 by roundinf bandwidth down to nearest integer

Revision a4a0f8db
Added by Steve Beaver 11 months ago

Fixed #6779 by rounding bandwidth down to nearest integer

History

#1 Updated by Vladimir Putin 11 months ago

It would be good to make target version 2.4 instead of nothing. Thanks.

#2 Updated by Jim Thompson 11 months ago

  • Category set to Traffic Shaper
  • Assignee set to Steve Beaver

#3 Updated by Steve Beaver 11 months ago

  • Status changed from New to Feedback
  • Assignee changed from Steve Beaver to Vladimir Putin

Would you please clarify for me?

Does the problem occur when you enter decimals in the wizard, or when values you enter in the wizard result in decimals after calculation?

Can you provide step by step instructions to reproduce please? Particularly "when you want to change something in queue settings this causes error messages in pfsense"

#4 Updated by Vladimir Putin 11 months ago

Yes, calculated values.
Run wizard, select Multiple Lan/Wan traffic_shaper_wizard_multi_all.xml
First step:
LAN/WAN number 1/1
Second step:
Setup connection speed and scheduler information for interface LAN #1:
HFSC
Setup connection speed and scheduler information for interface WAN#1:
HFSC
Upload/Download 300/300Mbit/s
Third step

Voice over IP
enable
Upload = download = 20 Mbit/s

Fourth step

Penalty box
Disabled
next.

Fifth step
Peer to Peer networking

Enable "Lower priority of Peer-to-Peer traffic"
Enable "p2pCatchAll" (bandwidth 15%)

Sixth step

skip everything to finish pressing next all the time.

After reloading filters, go to wan queue "qACK", under Service Curve (sc) you should see
bandwidth 15.666%, do not change anything, just try to press SAVE button.

15.666 value appears in config.xml:

You are welcome! %)

#5 Updated by Steve Beaver 11 months ago

  • Assignee changed from Vladimir Putin to Steve Beaver

Thanks!

I updated you instructions a little since "default" is not always the same in the Wizard.

#6 Updated by Steve Beaver 11 months ago

Fix part 1: HTML inputs that specify the bandwidth have been updated to accept decimal values.
Part 2: Calcualted bandwidths are now rounded down to the nearest integer.

#7 Updated by Steve Beaver 11 months ago

  • % Done changed from 0 to 100

#8 Updated by Vladimir Putin 11 months ago

Looks like fixed.

#9 Updated by Steve Beaver 11 months ago

  • Status changed from Feedback to Resolved

#10 Updated by Jim Pingle 7 months ago

  • Target version set to 2.3.3
  • Affected version set to All

Also available in: Atom PDF