Project

General

Profile

Bug #6860

Monitoring (RRD) graphs return "unknown" step value

Added by Jared Dillard about 1 year ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
RRD Graphs
Target version:
Start date:
10/17/2016
Due date:
% Done:

100%

Affected Version:
2.3.2
Affected Architecture:

Description

There seem to be cases where rrd_fetch_json.php returns a step value that isn't located in the javascript lookup table, leading to errors.

More details in this thread: https://forum.pfsense.org/index.php?topic=117036.0

History

#1 Updated by Jared Dillard 10 months ago

  • Status changed from Assigned to Feedback

I added the missing step (43200) to the lookup table.

#3 Updated by Jim Pingle 2 months ago

  • Status changed from Feedback to Assigned
  • Target version changed from 2.4.0 to 2.4.1

The step value from the last comment is still missing.

#4 Updated by Kill Bill about 1 month ago

Jared Dillard wrote:

Needs step 1800 added: https://forum.pfsense.org/index.php?topic=117036.msg695224#msg695224

https://github.com/pfsense/FreeBSD-ports/pull/432

Based on the description of the issue [1] from people that are able to reproduce it (I definitely am not one of them), I added all the halved values, to prevent more revisits to the code here.

[1] https://forum.pfsense.org/index.php?topic=117036.msg662322#msg662322

#5 Updated by Renato Botelho about 1 month ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

PR has been merged

#6 Updated by Jim Pingle about 1 month ago

  • Status changed from Feedback to Closed

I can't seem to break it now, but I couldn't reproduce the problem before, either, so it's a tough call on this one. The fixes are in place and appear to be good. If someone that could reproduce the error still has a problem, we can reopen this or start a new ticket for a later version.

#7 Updated by Jim Pingle about 1 month ago

  • Status changed from Closed to Resolved

Also available in: Atom PDF