Project

General

Profile

Actions

Bug #7022

closed

HAproxy action sequence bug

Added by Vladimir Tiukhtin over 5 years ago. Updated over 5 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
haproxy
Target version:
-
Start date:
12/20/2016
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

Web interface generate wrong action sequence in HAproxy config. See screenshots


Files

config.png (28.1 KB) config.png Vladimir Tiukhtin, 12/20/2016 03:11 AM
ps2.png (69.5 KB) ps2.png Vladimir Tiukhtin, 12/20/2016 03:11 AM
Actions #1

Updated by Kill Bill over 5 years ago

Fix the "tes" typo to "test" perhaps? Use https://forum.pfsense.org/index.php?board=60.0 for help, Redmine is for bugs.

Actions #2

Updated by Vladimir Tiukhtin over 5 years ago

Kill Bill wrote:

Fix the "tes" typo to "test" perhaps? Use https://forum.pfsense.org/index.php?board=60.0 for help, Redmine is for bugs.

There aren't any typos. There is a bug in config generator

Actions #3

Updated by Kill Bill over 5 years ago

Actually, no, there is no such bug. The redirect rules are ordered perfectly fine as declared. And there's nothing to order with a single use_backend rule. Plus all the stuff is ordered exactly as coded [1] (ACLs before actions before backend selection). If it does not do what you want it to do, then use the forums for support and explain what are you trying to do.

[1] https://github.com/pfsense/FreeBSD-ports/blob/devel/net/pfSense-pkg-haproxy/files/usr/local/pkg/haproxy/haproxy.inc#L1711

Actions #4

Updated by Vladimir Tiukhtin over 5 years ago

Kill Bill wrote:

Actually, no, there is no such bug. The redirect rules are ordered perfectly fine as declared. And there's nothing to order with a single use_backend rule. Plus all the stuff is ordered exactly as coded [1] (ACLs before actions before backend selection). If it does not do what you want it to do, then use the forums for support and explain what are you trying to do.

[1] https://github.com/pfsense/FreeBSD-ports/blob/devel/net/pfSense-pkg-haproxy/files/usr/local/pkg/haproxy/haproxy.inc#L1711

You don't understand. "use_backend" is always on bottom and there is no way to set it before, for example, "http-request". HAproxy allows this behavior

Actions #5

Updated by Kill Bill over 5 years ago

Yes, it is supposed to be always below the actions, I even linked the code and stated it explicitly. Dunno which part of "use the forum for help" is unclear, apparently a lost cause.

Actions #6

Updated by Jim Pingle over 5 years ago

  • Status changed from New to Not a Bug
  • Priority changed from High to Normal
Actions

Also available in: Atom PDF