Project

General

Profile

Actions

Bug #7295

closed

RFC2136 not updating at boot time

Added by Chris Macmahon over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Low
Category:
Dynamic DNS
Target version:
Start date:
02/22/2017
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4
Affected Architecture:
All

Description

Tracking pppoe interface, is not updating after IP change/reboot.

In logs, after forcing a manual update:

Feb 22 09:38:37    php-fpm    43405    /services_rfc2136_edit.php: Message sent to my.name@gmail.com OK
Feb 22 09:38:35    php-fpm    43405    /services_rfc2136_edit.php: phpDynDNS: updating cache file /conf/dyndns_opt4_rfc2136_'<username>.pfsense.io'_y.y.y.6.cache: x.x.x.224
Feb 22 09:38:33    check_reload_status        Syncing firewall
Feb 22 09:37:37    php-fpm    74350    /index.php: Successful login for user 'admin' from: z.z.z.54

settings from RFC2136 page:
Tracking DSL interface
TTY 30 seconds
<username>.pfsense.io
server: by ip not fqdn

Actions #1

Updated by Jim Pingle over 4 years ago

  • Subject changed from rfc 2136 to RFC2136 not updating at boot time
  • Description updated (diff)
  • Category set to Dynamic DNS
  • Target version set to 2.4.0
  • Affected Version set to 2.4
  • Affected Architecture All added
  • Affected Architecture deleted ()
Actions #2

Updated by Jim Pingle over 4 years ago

  • Description updated (diff)
Actions #3

Updated by Jim Thompson over 4 years ago

  • Assignee set to Renato Botelho
Actions #4

Updated by Renato Botelho over 4 years ago

  • Status changed from New to Feedback

Can you please try it again on recent snapshots? There were fixes in this area and I couldn't reproduce it at home where I have 2 PPPoE connections with RFC2136 hostnames working fine

Actions #5

Updated by Jim Pingle about 4 years ago

  • Status changed from Feedback to Resolved

It's working here as well, no problems with RFC2136 at boot on 2.4.

Actions

Also available in: Atom PDF