Project

General

Profile

Actions

Bug #7352

open

pfSense IPv6 static route is dumped after a WAN flap

Added by JC Denton over 4 years ago. Updated over 4 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Routing
Target version:
-
Start date:
03/05/2017
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3.2
Affected Architecture:
All

Description

In our pfSense setup, we receive a /56 prefix delegation (PD) from our ISP on the WAN. Two of our interfaces track the WAN to get their own /64s from this PD. Another /64 is statically routed to another host via pfSense's static routes. When the circuit flaps and the WAN briefly drops, this static route is lost and remains missing until it is manually applied from the admin interface. It seems like a bug not reapply static routes upon an interface's return, given that they are static (in nature).

Actions #1

Updated by Michael Zieher over 4 years ago

What happens if you just open a page (WAN Interface maybe), click 'save' without changing anything and 'apply'?

Actions #2

Updated by JC Denton over 4 years ago

Michael Zieher wrote:

What happens if you just open a page (WAN Interface maybe), click 'save' without changing anything and 'apply'?

That's what I do to restore the route. I "edit" the static route, make no changes, save & apply.

I had to do this today on the 2.3.4 update and also restart radvd because it wasn't serving RAs.

Actions

Also available in: Atom PDF