Project

General

Profile

Bug #7357

CloudFlare DDNS Not working for domain-only updates (@ record for domain)

Added by Jim Pingle over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Dynamic DNS
Target version:
Start date:
03/06/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

Since the CloudFlare DDNS code was changed to split hostname and domain, it is not possible to properly update the record for a domain since the GUI does not allow the hostname field to be blank or contain .

Forum post: https://forum.pfsense.org/index.php?topic=122099.msg697218#msg697218

Affects 2.3.3 and 2.4, older versions do not have the affected code changes.

To me, I have a fix tested by users on the forum.

Associated revisions

Revision 6534026b (diff)
Added by Jim Pingle over 2 years ago

Allow CloudFlare DDNS entries to use "" or "." for the hostname portion of the domain in the GUI to update the domain's @ record. Then in the backend code, remove that from the FQDN since CloudFlare doesn't like that to be sent explicitly. Fixes #7357

Fix is confirmed to work by two forum users: https://forum.pfsense.org/index.php?topic=122099.msg699763#msg699763

Revision f751b20a (diff)
Added by Jim Pingle over 2 years ago

Allow CloudFlare DDNS entries to use "" or "." for the hostname portion of the domain in the GUI to update the domain's @ record. Then in the backend code, remove that from the FQDN since CloudFlare doesn't like that to be sent explicitly. Fixes #7357

Fix is confirmed to work by two forum users: https://forum.pfsense.org/index.php?topic=122099.msg699763#msg699763

Revision a3d6987e (diff)
Added by Jim Pingle over 2 years ago

Allow CloudFlare DDNS entries to use "" or "." for the hostname portion of the domain in the GUI to update the domain's @ record. Then in the backend code, remove that from the FQDN since CloudFlare doesn't like that to be sent explicitly. Fixes #7357

Fix is confirmed to work by two forum users: https://forum.pfsense.org/index.php?topic=122099.msg699763#msg699763

History

#1 Updated by Jim Pingle over 2 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

#2 Updated by Renato Botelho over 2 years ago

  • Status changed from Feedback to Resolved

Confirmed fixed

Also available in: Atom PDF