Project

General

Profile

Bug #7473

Alias name change after input errors does not work

Added by Phillip Davis 4 months ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Rules/NAT
Target version:
Start date:
04/16/2017
Due date:
% Done:

0%

Affected version:
2.3.3_1
Affected Architecture:

Description

1) Edit an existing Alias that is used in a Rule/NAT etc - e.g. oldaliasname
2) Change the name - e.g. newaliasname
3) Change some IP address in the alias to an invalid string (so there will be input validation error(s) reported)
4) Press Save - the input validation errors are displayed
5) Fix up the invalid IP address to make it valid
6) Press Save again

Expected behaviour:
Uses of oldaliasname in Rules/NAT/etc will be updated to newaliasname

Actual behaviour:
oldaliasname remains in Rules/NAT/etc
errors are reported loading the rules

The problem is that on the first attempted Save, the code remembers "newaliasname" as if it was the "oldaliasname", and on the 2nd Save it does not think that the name has changed.

Can be reproduced on 2.3.* and 2.4 the same way.

History

#1 Updated by Jim Pingle 4 months ago

Duplicate of #7394

#2 Updated by Jim Pingle 4 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF