Project

General

Profile

Actions

Bug #7547

closed

Static routes using aliases are not automatically updated when alias content changes

Added by Chris Macmahon about 5 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Routing
Target version:
Start date:
05/12/2017
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Affected Version:
2.4.5-p1
Affected Architecture:

Description

When adding a new static route into an Alias group the route does not populate until a resave.
Steps to reproduce:
Create alias with static routes in it
Set static route with a static gateway
Add new route into the alias, check diagnostics routes, is enters as a /32, not as a full route.
Click static routes and resave
Route populates.


Related issues

Related to Bug #9743: Missing dependency check(s) on aliases in static routesDuplicate09/11/2019

Actions
Has duplicate Bug #11672: when setup Static Routes use aliases,cannot automatically learn that the aliases ip list has changedDuplicate03/13/2021

Actions
Actions #1

Updated by Dave Kobel over 3 years ago

Also, when you delete a subnet from the alias editing and saving the static alias route doesn't remove the route.
You either have to add the route manually, save and then go back and delete it, or reboot.
If the route is in a CARP, it's a bit better in that you can reboot the slave. At this point the slave shows the route deleted. The master still shows the route. On the master, enter maintenance in CARP and then reboot the master. When it comes back up you can remove the maintenance on the CARP.
Both issues has been this way since 2.0.3 (earliest I have run). Currently on 2.4.3p1

Actions #2

Updated by Jim Pingle over 1 year ago

See also: #9743, #11038

Actions #3

Updated by Kris Phillips over 1 year ago

I can confirm this issue is present in 2.4.5p1. The alias needs to be edited and resaved for the changes to take effect in routing.

Actions #4

Updated by Viktor Gurov over 1 year ago

  • Affected Version set to 2.4.5-p1
Actions #5

Updated by Jim Pingle about 1 year ago

  • Has duplicate Bug #11672: when setup Static Routes use aliases,cannot automatically learn that the aliases ip list has changed added
Actions #6

Updated by Jim Pingle about 1 year ago

  • Related to Bug #9743: Missing dependency check(s) on aliases in static routes added
Actions #8

Updated by Jim Pingle 9 months ago

  • Status changed from New to Pull Request Review
  • Target version set to CE-Next
  • Plus Target Version set to Plus-Next
Actions #9

Updated by Marcos Mendoza 6 months ago

See notes on #11599.

Actions #10

Updated by Viktor Gurov 6 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #11

Updated by Danilo Zrenjanin 6 months ago

  • Status changed from Feedback to Resolved

Tested against:

2.6.0-DEVELOPMENT (amd64)
built on Tue Nov 30 06:19:18 UTC 2021
FreeBSD 12.3-PRERELEASE

It works as expected. Ticket resolved.

Actions #12

Updated by Jim Pingle 5 months ago

  • Subject changed from Static routing with Aliases to Static routes using aliases are not automatically updated when alias content changes
  • Target version changed from CE-Next to 2.6.0
  • Plus Target Version changed from Plus-Next to 22.01

Updating subject for release notes and fixing targets.

Actions

Also available in: Atom PDF