Project

General

Profile

Bug #7569

openvpn wizard reused settings cause wrong defaults

Added by Jeremy C. Reed 6 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
Start date:
05/20/2017
Due date:
% Done:

100%

Affected Version:
All
Affected Architecture:
All

Description

wizards/openvpn_wizard.xml
This is a wizards behavior which can cause confusion or mistake.
A wizard saves its settings to config.xml
and if you use the wizard again it may prepopulate fields.

So if you use the wizard once to setup an LDAP server
the later setup a RADIUS server, it may have the 389 port number
(for LDAP) for the RADIUS port setup. Even though it has
the correct number in note below, the common usage for pfSense is
to prepopulate with defaults. In this case, the field is wrong.

Associated revisions

Revision 7120ef41
Added by Jim Pingle 6 months ago

In the OpenVPN wizard, if the user chooses a different auth server type, clear out stored settings so the wizard does not pre-fill bad info. Fixes #7569

History

#1 Updated by Jim Pingle 6 months ago

  • Category changed from VPN to OpenVPN
  • Status changed from New to Assigned
  • Assignee set to Jim Pingle
  • Target version set to 2.4.0
  • Affected Version set to All
  • Affected Architecture set to All

#2 Updated by Jim Pingle 6 months ago

  • Subject changed from openvon wizard reused settings cause wrong defaults to openvpn wizard reused settings cause wrong defaults

#3 Updated by Jim Pingle 6 months ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

#4 Updated by Jim Pingle 5 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF