Project

General

Profile

Bug #7682

system_authservers delete UI bugs

Added by Phillip Davis over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
07/08/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

1) In system_authservers, have a list of at least 3 extra auth servers defined, and Local Database will be at the end of the list.
2) Delete the 1ist entry in the list - it is deleted fine
3) Problem - the edit and delete buttons are missing from the auth server in the row above "Local Database"
4) Edit one of the auth servers that has an edit button
5) Problem - a different auth server is opened for editing than the one that you clicked
(and similar problem if you use delete)

Root cause: the local array of auth servers used to build the page for display is not correctly closed up to reflect the entry just deleted from the config.

Associated revisions

Revision 4e4cac0d (diff)
Added by Jim Pingle over 2 years ago

Improve the way the auth server list is generated and account for a key being removed from the array when deleting. Fixes #7682

Revision fa628b1a (diff)
Added by Jim Pingle over 2 years ago

Improve the way the auth server list is generated and account for a key being removed from the array when deleting. Fixes #7682

Revision 02068d31 (diff)
Added by Jim Pingle over 2 years ago

Improve the way the auth server list is generated and account for a key being removed from the array when deleting. Fixes #7682

(cherry picked from commit fa628b1a15a1c03343caa2735e09de291ae4e382)

History

#1 Updated by Phillip Davis over 2 years ago

master: https://github.com/pfsense/pfsense/pull/3780
RELENG_2_3:https://github.com/pfsense/pfsense/pull/3778
RELENG_2_3_4: https://github.com/pfsense/pfsense/pull/3779

#2 Updated by Jim Pingle over 2 years ago

  • Category set to Web Interface
  • Target version set to 2.4.0
  • Affected Architecture set to All

The fix seems to work but it could be better/simpler, see my comments on PR 3780.

#3 Updated by Jim Pingle over 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#4 Updated by Jim Pingle over 2 years ago

  • Target version changed from 2.4.0 to 2.3.4-p1

#5 Updated by Jim Pingle over 2 years ago

  • Status changed from Feedback to Resolved

Works.

Also available in: Atom PDF