Project

General

Profile

Actions

Bug #7690

closed

System Domain Local Zone Type option Redirect is broken

Added by Renato Botelho over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DNS Resolver
Target version:
Start date:
07/12/2017
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

If user chose option 'Redirect' on 'System Domain Local Zone Type' in services_unbound.php unbound doesn't start with the following error:

Jul 12 14:28:24 pfs24-amd64-1 unbound: [84655:0] error: local-data in redirect zone must reside at top of zone, not at pfs24-amd64-1.home A 172.16.185.241
Jul 12 14:28:24 pfs24-amd64-1 unbound: [84655:0] fatal error: Could not set up local zones

After that you cannot back it to another option because when Save button is pressed it shows an error saying config file is invalid

Actions #1

Updated by Jim Pingle over 4 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #2

Updated by Jim Pingle over 4 years ago

  • Status changed from Feedback to Confirmed

Still needs the fix ported to 2.3.x, it did not cherry-pick cleanly.

Actions #3

Updated by Jim Pingle over 4 years ago

  • Status changed from Confirmed to Feedback
Actions #4

Updated by Renato Botelho over 4 years ago

  • Status changed from Feedback to Resolved

Works

Actions

Also available in: Atom PDF