Project

General

Profile

Actions

Bug #771

closed

Gateway upgrade code is broken.

Added by Seth Mos over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
Routing
Target version:
Start date:
07/30/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

The gateway upgrade code is broken. I had a working snapshot from june 17th, I've confirmed that july 28th does not work.

I can not narrow down the snapshots further but here is the config.xml that is related to the issue. This also leaves the system without a default route after a upgrade.

On the june 17th snapshot I have 5 gateways defined as it should, 1 default gateway and 4 from static routes.
On the july 28th snapshot I have 0 gateways and the XML only contains a single $config['gateways']['gateway_item'] with just the single monitor IP address entry, nothing else.

A upgrade from 1.2-RELEASE to 2.0B3 (june 27th) and then 2.0B4 (july 28th) does work and leaves the gateway config.xml intact.


Related issues

Related to Bug #480: Monitor IP config upgrade doesn't workResolved04/04/2010

Actions
Actions #2

Updated by Ermal Luçi over 11 years ago

  • Status changed from New to Feedback

Seth committed code himself for this so i am putting to feedback.

Actions #3

Updated by Seth Mos over 11 years ago

Need to wait for a snapshot to confirm fixed, I tried a manual upgrade by hacking the code before completing boot. Which worked.

Update: Fixed.

Actions #4

Updated by Seth Mos over 11 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF