Project

General

Profile

Bug #7733

User Manager deletes non-selected users

Added by Tom Wijnroks 5 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
User manager
Target version:
Start date:
07/28/2017
Due date:
% Done:

100%

Affected Version:
2.3.4
Affected Architecture:

Description

The User Manager seems to delete non-selected (wrong) users when using the 'red' delete button on the bottom of the Users page. It seems that, after deleting one or more users, a hard page refresh is required first, else it somehow uses the next user ID on the users page.

Steps to reproduce:
1. Go to System > User Manager > Users
2. Add 3 users, for example: aaa, bbb, ccc
3. Select user 'aaa' and use the red delete button (the one at the bottom)
4. Now select user 'bbb' and again, use the red delete button
5. The result is: "User ccc successfully deleted."

If you would have selected user 'ccc' in step 4, it would try to delete the admin user, which luckily is not possible.

This also happens if you select/delete multiple users. I ran into this because it deleted 3 users i didn't select.

Software i used to test:
- pfSense: 2.3.4-RELEASE-p1 (amd64)
- Chrome 59.0.3071.115 (Official Build) (64-bit)
- Firefox 54.0.1 (64-bit)

Associated revisions

Revision 92c27793
Added by Jim Pingle about 2 months ago

Reindex the user and group arrays after deleting items, to avoid operating on incorrect array entries. Fixes #7733

Revision 106de636
Added by Jim Pingle about 2 months ago

Reindex the user and group arrays after deleting items, to avoid operating on incorrect array entries. Fixes #7733

(cherry picked from commit 92c27793b4c7f87e89aec3faec5582c17502d6d5)

Revision 09038b21
Added by Jim Pingle about 2 months ago

Reindex the user and group arrays after deleting items, to avoid operating on incorrect array entries. Fixes #7733

(cherry picked from commit 92c27793b4c7f87e89aec3faec5582c17502d6d5)
(cherry picked from commit 106de6365c7407f2325d5b3e07625620c10436d0)

History

#1 Updated by Jim Pingle about 2 months ago

  • Target version changed from 2.3.4_2 to 2.4.2

I can't reproduce this as stated, the second delete attempt actually does nothing, rather than deleting anything as the issue description says. We will need more time to investigate.

#2 Updated by Jim Thompson about 2 months ago

  • Assignee set to Jim Pingle

#3 Updated by Jim Pingle about 2 months ago

This turned out to the same sort of issue as #7682 (on a different page, however), and a similar fix addressed the problem. Fix will be pushed momentarily.

#4 Updated by Jim Pingle about 2 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#5 Updated by Tom Wijnroks about 2 months ago

Jim Pingle wrote:

This turned out to the same sort of issue as #7682 (on a different page, however), and a similar fix addressed the problem. Fix will be pushed momentarily.

Thanks for fixing it Jim!

#6 Updated by Jim Pingle about 1 month ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF