Project

General

Profile

Bug #7784

IPsec widget breaks dashboard loading

Added by Kill Bill 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
08/19/2017
Due date:
% Done:

0%

Affected Version:
2.4
Affected Architecture:
All

Description

CPU usage does not finish loading, interface statistics, NTP neither.

    Uncaught SyntaxError: Unexpected end of JSON input
    at JSON.parse (<anonymous>)
    at Object.ipsec_callback [as callback] (gw.example.com/:1348)
    at Object.success (gw.example.com/:3573)
    at i (jquery-1.12.0.min.js:2)
    at Object.fireWith [as resolveWith] (jquery-1.12.0.min.js:2)
    at y (jquery-1.12.0.min.js:4)
    at XMLHttpRequest.c (jquery-1.12.0.min.js:4)

2.4 snapshot: Fri Aug 18 00:32:41 CDT 2017

History

#1 Updated by Steve Beaver 4 months ago

  • Assignee set to Steve Beaver

I am unable to reproduce.

Would you tell me your OS and browser versions please, as well as your current dashboard setup (widgets enabled, number of IPSec tunnels) and anything els eyou can think of that might help?

Thanks

#2 Updated by Kill Bill 4 months ago

There's just one IPsec tunnel (and mobile IPsec server). I don't think the OS/browser matters. Same thing with Chrome v60, FF v55, both on Windows and Linux.

Gets stuck at "Retrieving overview data". When I switch to Tunnel/Mobile tab, it gets stuck there as well (Retrieving tunnel/mobile data). Actually the tunnel/mobile tabs are much worse, getting "TypeError: d.getSeconds is not a function" every second in addition. I tried with the tunnel disconnected and connected, makes no difference.

Widgets:
- System Information
- Services Status
- Thermal Sensors
- OpenVPN
- IPsec
- SMART
- Squid
- Interfaces
- Gateways
- Interfaces Statistics
- NTP Status
- DynDNS Status
- Traffic Graphs
- Firewall Logs
- pfBlockerNG
- Suricata

#3 Updated by Steve Beaver 4 months ago

Thanks for the information. We have still not been able to reproduce but will keep trying.

The IPSec tab you select should't matter any more since the AJAX call returns a JSON formatted list of the overview, tunnels, and mobile data on every call no matter which tab is selected. I have been monitoring using Firefox "Network" tab and verified that on my systems this is working as expected. The POST and the response look good.

Thanks again for the help.

#4 Updated by Kill Bill 4 months ago

OK, it's caused by the mobile tunnel. If you put

$jsondata .= "\"}";


before the
print($jsondata);

line, then the issue is gone. The else statement should go to /dev/null, I'd say. Like this, perhaps? https://github.com/pfsense/pfsense/pull/3803

Note: The d.getSeconds is not a function problem with tunnels/mobile tabs persists even after the above fix.

#5 Updated by Steve Beaver 4 months ago

  • Status changed from New to Feedback

Updated per your PR. Thank you!

#6 Updated by Kill Bill 4 months ago

Is this actually committed somewhere? Nowhere on GitHub, no new snapshot either.

#7 Updated by Steve Beaver 4 months ago

Github sync will resume shortly. We are making some changes in anticipation of 2.4 RC and needed to briefly pause it.

#8 Updated by Kill Bill 4 months ago

Works in 2.4 RC.

#9 Updated by Steve Beaver 4 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF