Project

General

Profile

Bug #7946

2.4 Package Manager: Does Not List Installed Packages which have been removed from the repository.

Added by Andrew Barnes almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
Package System
Target version:
Start date:
10/15/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4
Affected Architecture:

Description

Upon upgrading to pfSense 2.4, I was unable to perform the recommended approach to move from freeradius 2.x to 3.x because 2.x would not appear in the list of installed packages (so I could uninstall 2.x).

The workaround was to uninstall the package via the command line:

pkg delete <pkg name> -y

Note: "pkg info" will still list the pkg as being installed, as will the services dialog/etc even upon logout/login. I did not try a reboot.

I don't know if this is the case for other packages.

Addendum: v2.4 effectively breaks freeradius 2.x - the service will not start.

Associated revisions

Revision 44cb7fee (diff)
Added by Renato Botelho almost 2 years ago

Fix #7946: Display installed packages missing on remote repo to let user to delete it

Revision a16690c8 (diff)
Added by Renato Botelho almost 2 years ago

Fix #7946: Display installed packages missing on remote repo to let user to delete it

Revision 42b6ca6e (diff)
Added by Renato Botelho almost 2 years ago

Fix #7946: Display installed packages missing on remote repo to let user to delete it

Revision a9b0a7a3 (diff)
Added by Renato Botelho almost 2 years ago

Fix #7946: Display installed packages missing on remote repo to let user to delete it

History

#2 Updated by Jim Pingle almost 2 years ago

  • Project changed from pfSense Packages to pfSense
  • Subject changed from 2.4 Package Manager: Does Not List Freeradius 2.x to 2.4 Package Manager: Does Not List Installed Packages which have been removed from the repository.
  • Category set to Package System
  • Assignee set to Renato Botelho
  • Target version set to 2.4.2

It may still be a bug though. The package is indeed gone from the server-side database but it's still installed locally. It has to be removed, but it appears that the GUI won't let you since it isn't listed.

Ideally, the package should still show up in the list of installed packages so that it can be removed from there, and marked as having been removed upstream.

I suspect this may also be in some way related to #7917

#3 Updated by Kill Bill almost 2 years ago

Well yes, the inability to produce/take into account any offline results is indeed a bug.

#4 Updated by Jim Pingle almost 2 years ago

It seems to be anything it can't validate against the current repository (offline or online). It should list them all in either case, and the root cause may be the same here.

#5 Updated by Kill Bill almost 2 years ago

Apparently this has already been reported in Bug #6241

#6 Updated by Jim Pingle almost 2 years ago

I closed that one out instead, since this one is already setup for the right target.

#7 Updated by Renato Botelho almost 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#8 Updated by James Dekker almost 2 years ago

freeradius2 remained at Installed Packages in the WebGUI. Fix confirmed.

#9 Updated by Renato Botelho almost 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF