Project

General

Profile

Actions

Bug #8223

closed

Cannot delete vlan, I get redirected to an empty page

Added by Alexandre Paradis over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
12/17/2017
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.3
Affected Architecture:

Description

The page I get redirected is : https://192.168.5.2/interfaces_vlan_new_prof.php

404 Not Found
nginx

Using version

2.4.3-DEVELOPMENT (amd64)
built on Fri Dec 15 09:33:08 CST 2017
FreeBSD 11.1-RELEASE-p6

Actions #1

Updated by Anonymous over 4 years ago

  • Status changed from New to Closed

Unable to reproduce
There is no interfaces_vlan_new_prof.php page in pfSense

Suggest you discuss on the forum.

Actions #2

Updated by Jim Pingle over 4 years ago

  • Status changed from Closed to New

That page doesn't exist, but there is a reference to it: https://github.com/pfsense/pfsense/blob/master/src/usr/local/www/interfaces_vlan.php#L87

Looks like the bugs were introduced during a recent pull request merge: https://github.com/pfsense/pfsense/pull/3868

That PR is probably also the root cause of #8222

Actions #3

Updated by Anonymous over 4 years ago

Yes. let's back out that PR.

Actions #4

Updated by Anonymous over 4 years ago

PR reverted.

Actions #5

Updated by Jim Pingle over 4 years ago

  • Status changed from New to Feedback
Actions #6

Updated by Peter Schofield over 4 years ago

This should now be fixed; I corrected the broken reference.

Actions #7

Updated by Alexandre Paradis over 4 years ago

Using

2.4.3-DEVELOPMENT (amd64)
built on Tue Dec 19 18:22:48 CST 2017
FreeBSD 11.1-RELEASE-p6

I can say it's fixed :)

Thanks!

Actions #8

Updated by Jim Pingle over 4 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF