Project

General

Profile

Bug #8322

PPP UI error

Added by Steve Beaver over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
02/07/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.2_1
Affected Architecture:

Description

Warning: array_merge(): Argument #2 is not an array in /etc/inc/interfaces.inc on line 6664 Catchable fatal error: Argument 4 passed to Form_Select::__construct() must be of the type array, null given, called in /usr/local/www/interfaces_ppps_edit.php on line 507 and defined in /usr/local/www/classes/Form/Select.class.php on line 29 PHP ERROR: Type: 4096, File: /usr/local/www/classes/Form/Select.class.php, Line: 29, Message: Argument 4 passed to Form_Select::__construct() must be of the type array, null given, called in /usr/local/www/interfaces_ppps_edit.php on line 507 and defined

Associated revisions

Revision b0e29e62 (diff)
Added by Steve Beaver over 1 year ago

Fixed #8322 to accommodate case where no VIPs are defined

History

#1 Updated by Steve Beaver over 1 year ago

  • Status changed from New to Feedback

Fixed by initializing VIP array in interfaces.inc

#2 Updated by Steve Beaver over 1 year ago

  • % Done changed from 0 to 100

#3 Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF