Project

General

Profile

Bug #8494

pressing Enter in pftop filter field redirects to another page

Added by Constantine Kormashev 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Web Interface
Target version:
Start date:
05/03/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

If I press Enter in pftop filter field system redirects me to another page instead showing result in Output frame.

E.g.
for host 1.1.1.1 it shows

pfTop: Up State no entries (8), View: default, Order: bytes PR DIR SRC DEST STATE AGE EXP PKTS BYTES

1.1.1.1

for host 172.21.41.127 it shows

pfTop: Up State 1-2/2 (9), View: default, Order: bytes PR DIR SRC DEST STATE AGE EXP PKTS BYTES udp In 172.21.41.127:1194 172.21.41.138:1194 MULTIPLE:MULTIPLE 01:21:35 00:00:58 1285 169271 udp In 172.21.41.127:17500 172.21.41.255:17500 NO_TRAFFIC:SINGLE 00:16:39 00:00:22 34 6664

172.21.41.127

And for any wrong syntax request it shows

Invalid filter, check syntax

syntax error

Video demonstrates the issue:
https://youtu.be/TWqdtVJSO_8?t=3m9s

1111.png (11.8 KB) 1111.png 1.1.1.1 Constantine Kormashev, 05/03/2018 04:38 AM
1722141127.png (16.9 KB) 1722141127.png 172.21.41.127 Constantine Kormashev, 05/03/2018 04:38 AM
err.png (7.03 KB) err.png syntax error Constantine Kormashev, 05/03/2018 04:40 AM

Associated revisions

Revision e2654541 (diff)
Added by Jim Pingle 11 months ago

Prevent pressing Enter in the filter field of diag_pftop.php. Fixes #8494

Revision ab1387e6 (diff)
Added by Jim Pingle 11 months ago

Prevent pressing Enter in the filter field of diag_pftop.php. Fixes #8494

(cherry picked from commit e2654541019b59f544cda76fb0e63ea7a4a5d040)

Revision 4ce3d0ac (diff)
Added by Jim Pingle 11 months ago

Prevent pressing Enter in the filter field of diag_pftop.php. Fixes #8494

(cherry picked from commit e2654541019b59f544cda76fb0e63ea7a4a5d040)

Revision 81852be2 (diff)
Added by Jim Pingle 11 months ago

Prevent pressing Enter in the filter field of diag_pftop.php. Fixes #8494

(cherry picked from commit e2654541019b59f544cda76fb0e63ea7a4a5d040)

History

#1 Updated by Jim Pingle 11 months ago

  • Status changed from New to Confirmed
  • Assignee set to Jim Pingle
  • Target version set to 2.4.4
  • Affected Version set to All
  • Affected Architecture set to All

#2 Updated by Jim Pingle 11 months ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#3 Updated by Jim Pingle 11 months ago

  • Target version changed from 2.4.4 to 2.4.3_1

#4 Updated by James Dekker 11 months ago

The issue is not present on latest 2.4.4 snap (2.4.4.a.20180504.0747).

#5 Updated by Jim Pingle 11 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF