Project

General

Profile

Bug #8730

NAT PHP7 errors.

Added by Anonymous over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/01/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:

Description

I found several PHP7 issues while running through some tests for NAT.

Warning: Illegal string offset 'rule' in /usr/local/www/firewall_nat.php on line 40 Warning: Illegal string offset 'rule' in /usr/local/www/firewall_nat.php on line 43 Fatal error: Uncaught Error: Cannot create references to/from string offsets in /usr/local/www/firewall_nat.php:43 Stack trace: #0 {main} thrown in /usr/local/www/firewall_nat.php on line 43 PHP ERROR: Type: 1, File: /usr/local/www/firewall_nat.php, Line: 43, Message: Uncaught Error: Cannot create references to/from string offsets in /usr/local/www/firewall_nat.php:43 Stack trace: #0 {main} thrown

Warning: Illegal string offset 'outbound' in /usr/local/www/firewall_nat_out.php on line 42 Warning: Illegal string offset 'outbound' in /usr/local/www/firewall_nat_out.php on line 46 Fatal error: Uncaught Error: Cannot use string offset as an array in /usr/local/www/firewall_nat_out.php:46 Stack trace: #0 {main} thrown in /usr/local/www/firewall_nat_out.php on line 46 PHP ERROR: Type: 1, File: /usr/local/www/firewall_nat_out.php, Line: 46, Message: Uncaught Error: Cannot use string offset as an array in /usr/local/www/firewall_nat_out.php:46 Stack trace: #0 {main} thrown

Warning: Illegal string offset 'outbound' in /usr/local/www/firewall_nat_out_edit.php on line 39 Warning: Illegal string offset 'outbound' in /usr/local/www/firewall_nat_out_edit.php on line 43 Fatal error: Uncaught Error: Cannot use string offset as an array in /usr/local/www/firewall_nat_out_edit.php:43 Stack trace: #0 {main} thrown in /usr/local/www/firewall_nat_out_edit.php on line 43 PHP ERROR: Type: 1, File: /usr/local/www/firewall_nat_out_edit.php, Line: 43, Message: Uncaught Error: Cannot use string offset as an array in /usr/local/www/firewall_nat_out_edit.php:43 Stack trace: #0 {main} thrown

Associated revisions

Revision 5c674b1e (diff)
Added by Stephen Jones over 1 year ago

Fixes #8730 PHP7 issues illegal string offsets

History

#1 Updated by Anonymous over 1 year ago

  • Status changed from New to In Progress

#2 Updated by Anonymous over 1 year ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100

#3 Updated by James Dekker over 1 year ago

On 2.4.4.a.20180803.1120, cannot reproduce.

#4 Updated by James Dekker over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF