Project

General

Profile

Bug #8745

Adding a bridge generates a crash report.

Added by James Dekker 11 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Interfaces
Target version:
Start date:
08/03/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:

Description

Visit Interfaces > Assignments, then click on Bridges. Once there, click +Add, select an interface or interfaces, slick Save.

Visit the dashboard and a crash report will be generated.

Crash report begins.  Anonymous machine information:

amd64
11.2-RELEASE
FreeBSD 11.2-RELEASE #48 cd0e4c8cf25(RELENG_2_4_4): Fri Aug  3 11:21:26 EDT 2018     root@buildbot3:/builder/crossbuild-ce-master/obj/amd64/FWJoMRHc/builder/crossbuild-ce-master/pfSense/tmp/FreeBSD-src/sys/pfSense

Crash report details:

PHP Errors:
[03-Aug-2018 20:18:28 Etc/UTC] PHP Warning:  exec(): NULL byte detected. Possible attack in /etc/inc/util.inc on line 1712
[03-Aug-2018 20:18:28 Etc/UTC] PHP Warning:  exec(): NULL byte detected. Possible attack in /etc/inc/util.inc on line 1712

No FreeBSD crash data found.

Associated revisions

Revision 71de53e3 (diff)
Added by Steve Beaver 10 months ago

Fixed #8745 by trimming nulls from bridgeif

History

#1 Updated by Steve Beaver 10 months ago

  • Assignee set to Steve Beaver

#2 Updated by Steve Beaver 10 months ago

  • Status changed from New to In Progress

#3 Updated by Steve Beaver 10 months ago

  • Status changed from In Progress to Feedback

#4 Updated by Steve Beaver 10 months ago

  • % Done changed from 0 to 100

#5 Updated by James Dekker 10 months ago

On 2.4.4.a.20180815.1003, cannot reproduce.

#6 Updated by James Dekker 10 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF