Project

General

Profile

Bug #8762

PHP OpenSSL CRL patch fails with PHP 7.2

Added by Jim Pingle 12 months ago.

Status:
Resolved
Priority:
Very High
Assignee:
Category:
Certificates
Target version:
Start date:
08/07/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:
All

Description

Change CRL generation to a pure PHP implementation which works with PHP 7.2 (and 5.6)

The old OpenSSL CRL patch we had been using does not work with 7.2, and this way also opens up some new possibilities for enhancing the CRL settings we can offer in the future.

Implemented in 981d6364 but did not have a Redmine entry

Also available in: Atom PDF