Project

General

Profile

Actions

Feature #8812

closed

Add "Select All" to Firewall/NAT rule lists

Added by reza mansoorpour almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Rules / NAT
Target version:
Start date:
08/20/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:

Description

pfSense does not have select all (Firewall -> Rules).
cannot select all rows in firewall rules.
imagine firewall rule has 1000 row and want select all or reverse select.


Files

Screenshot from 2018-08-20 11-30-16.png (67.7 KB) Screenshot from 2018-08-20 11-30-16.png reza mansoorpour, 08/20/2018 02:34 AM
Selection_476.png (38.2 KB) Selection_476.png Steve Wheeler, 08/25/2018 08:03 AM
Actions #1

Updated by Jim Pingle almost 4 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from pfsense has forgotten the select all to Add "Select All" to Firewall/NAT rule lists
  • Description updated (diff)
  • Category set to Rules / NAT
  • Target version set to Future

Not a bug, but a feature request. That page has not had a select all mechanism that I could see. Checked back to 2.1.

Actions #2

Updated by Anonymous almost 4 years ago

  • Status changed from New to Feedback
  • Assignee set to Anonymous
Actions #3

Updated by Anonymous almost 4 years ago

  • Target version changed from Future to 2.4.4
Actions #4

Updated by Anonymous almost 4 years ago

  • % Done changed from 0 to 100
Actions #5

Updated by Constantine Kormashev almost 4 years ago

New feature works fine for:
firewall_nat.php
firewall_rules.php

But does not exist for:
firewall_nat_1to1.php
firewall_nat_out.php
firewall_nat_npt.php

Actions #6

Updated by Constantine Kormashev almost 4 years ago

  • Status changed from Feedback to Assigned
Actions #7

Updated by Anonymous almost 4 years ago

  • Status changed from Assigned to Feedback

Control has been added to all NAT pages

Actions #8

Updated by Steve Wheeler over 3 years ago

The control is now present on NAT rules but does not seem to actually function. Clicking 'select all' does not select anything. See screenshot:

Tested in:

2.4.4-DEVELOPMENT (amd64)
built on Fri Aug 24 16:24:53 EDT 2018
FreeBSD 11.2-RELEASE-p2

Actions #9

Updated by Steve Wheeler over 3 years ago

  • Status changed from Feedback to Assigned
Actions #10

Updated by Anonymous over 3 years ago

  • Status changed from Assigned to Feedback

Rule table given ID so selectall control can find it

Actions #11

Updated by Anonymous over 3 years ago

Select all works as expected on Firewall > NAT > Port Forward/1:1/Outbound/NPt and at Firewall > Rules on 2.4.4.a.20180824.1144 (gitsync'd to master).

Actions #12

Updated by Anonymous over 3 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF