Project

General

Profile

Bug #8834

NAT > NPt address fields do not match the hover text

Added by James Dekker 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
08/25/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.x
Affected Architecture:

Description

Visit Firewall > NAT > NPt, click add, hover over each Address field.

Notice that the first Address field description is

Internal (LAN) ULA IPv6 Prefix for the Network Prefix translation. The prefix size specified for the internal IPv6 prefix will be applied to the external prefix.

But the hover text says

An IPv4 address like 1.2.3.4 or an IPv6 address like 1:2a:3b:ffff::1 or an alias

Also notice the second Address field description is

Global Unicast routable IPv6 prefix

But the hover text says

An IPv4 address like 1.2.3.4 or an IPv6 address like 1:2a:3b:ffff::1 or an alias
25-08-2018_16_30_27.png (11.6 KB) 25-08-2018_16_30_27.png James Dekker, 08/25/2018 03:31 PM
25-08-2018_16_30_35.png (9.06 KB) 25-08-2018_16_30_35.png James Dekker, 08/25/2018 03:32 PM

Associated revisions

Revision c1004c84 (diff)
Added by Jim Pingle 9 months ago

Add missing break in IpAddress form class. Fixes #8834

History

#1 Updated by Jim Pingle 9 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#2 Updated by James Dekker 9 months ago

On 2.4.4.a.20180825.0917 (gitsync'd to master) looks good. Hover text accurately reflects the description (shown in the attached screenshots)

#3 Updated by James Dekker 9 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF