Project

General

Profile

Bug #8885

HAProxy "Log hostname parameter broke local syslog

Added by DRago_Angel [InV@DER] almost 2 years ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
haproxy
Target version:
-
Start date:
09/11/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

History

#1 Updated by DRago_Angel [InV@DER] almost 2 years ago

Package Version:
haproxy-devel net 0.59_9

Package Dependencies:
haproxy-devel-1.8.13 

cat /etc/version
2.4.3-RELEASE

cat /etc/version.buildtime
Thu May 10 15:02:52 CDT 2018

How to reproduce:
1. Install and configure HAproxy for simple any one frontend/backend
2. Configure Remote syslog host: /var/run/log
3. Syslog facility: local0
P.S. Not exist Syslog facility for haproxy, don't described and not limited what syslog facilities better not use locally (if setup syslog host: /var/run/log).
4. Syslog level: any
5. Log hostname: if this field not NULL or not haproxy then /var/run/log not write it in /var/log/haproxy.log because of /etc/syslogd.conf filter.

#2 Updated by Jared Dillard over 1 year ago

  • Category set to haproxy

#3 Updated by Viktor Gurov 6 months ago

  • Status changed from New to Closed

no such issue with haproxy-devel 0.60_3 on pfSense 2.4.5.r.20200225.2100 and 2.5.0.a.20200225.0859
- hostname field can be any, logging works ok

Also available in: Atom PDF