Project

General

Profile

Actions

Bug #8893

closed

Outbound NAT page unnecessarily strips underscores from alias names

Added by → luckman212 about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
09/13/2018
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.x
Affected Architecture:
All

Description

I notice that underscores are being replaced with spaces in alias names on Firewall > NAT > Outbound.
It's not consistent with the rest of the UI.

this commit should fix the issue
https://github.com/luckman212/pfsense/commit/42c059894a4a521415c35dc048952658f61fad65

Actions #1

Updated by Jim Pingle about 3 years ago

  • Status changed from New to Not a Bug
  • Target version deleted (2.4.4)
  • Affected Version deleted (2.4.3_1)

It's done deliberately to avoid long aliases preventing wrapping. #7249

Actions #2

Updated by → luckman212 about 3 years ago

The change above substitutes '_' with '_<wbr>' which is the same method used on other NAT pages. The '<wbr>' signals that it's ok for the browser to break there and so it allows wrapping to happen while still preserving the underscores. This seems like the right thing to me.
https://github.com/pfsense/pfsense/pull/3980#issuecomment-421350916

Actions #3

Updated by Jim Pingle about 3 years ago

  • Status changed from Not a Bug to New
  • Target version set to 2.4.4-GS
  • Affected Version set to 2.4.x
  • Affected Architecture All added
  • Affected Architecture deleted ()

You are right that one page is inconsistent with the rest. They should all be done the same way. Not going to hold back 2.4.4 for a minor change like this though.

Actions #4

Updated by Renato Botelho about 3 years ago

  • Status changed from New to Feedback
  • Assignee set to Renato Botelho

PR merged

Actions #5

Updated by Steve Wheeler about 3 years ago

  • Status changed from Feedback to Resolved

Looks good.

Tested in:

2.4.5-DEVELOPMENT (amd64)
built on Mon Oct 01 01:24:24 EDT 2018
FreeBSD 11.2-RELEASE-p4
Actions #6

Updated by Steve Beaver about 3 years ago

  • Target version changed from 2.4.4-GS to 2.4.4-p1
Actions #7

Updated by Steve Beaver about 3 years ago

  • Target version changed from 2.4.4-p1 to 2.4.4-GS
Actions

Also available in: Atom PDF