Project

General

Profile

Bug #8949

DHCPv6 Server Network Booting fails to be set

Added by Andrew Stuart over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
DHCP (IPv6)
Target version:
Start date:
09/25/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.4
Affected Architecture:

Description

Checking "Enable Network Booting" under "Display Advanced" and clicking Save doesn't record

<dhcpvdv6> 
   <netboot></netboot>
</dhcpdv6> 

to config.xml thus [[https://github.com/pfsense/pfsense/blob/ed089dc3624c10036bc357c7d40d779a7cc965d6/src/etc/inc/services.inc#L1356]] never returns true.

Steps to replicate:
Enable DHCPv6 Server
Click Network Booting -> Display Advanced
Check Enable Network Booting
Click Save

Notice Enable Network Booting is checked
Click Services -> DHCPv6 Server & RA
Click Network Booting -> Display Advanced
Notice the box is unchecked

I believe this bug also impacts 2.3(.x), I just never got around to reporting it.

Associated revisions

Revision e46ea2c6 (diff)
Added by Stephen Jones over 2 years ago

Fixes #8949 Looks like there was 2 variable names for the same variable shownetboot and netboot. It now just uses the variable name netboot

Revision 68cba33c (diff)
Added by Stephen Jones over 2 years ago

Fixes #8949 Looks like there was 2 variable names for the same variable shownetboot and netboot. It now just uses the variable name netboot

(cherry picked from commit e46ea2c60986c62371966025ab3068466217fefa)

History

#1 Updated by Anonymous over 2 years ago

  • Status changed from New to Assigned
  • Assignee set to Anonymous

#2 Updated by Anonymous over 2 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

#3 Updated by Andrew Stuart over 2 years ago

I have confirmed that this now works as expected. Thank you for the quick fix.

#4 Updated by Renato Botelho over 2 years ago

  • Status changed from Feedback to Resolved

#5 Updated by Steve Beaver over 2 years ago

  • Target version changed from 2.4.4-GS to 2.4.4-p1

#6 Updated by Steve Beaver over 2 years ago

  • Target version changed from 2.4.4-p1 to 2.4.4-GS

Also available in: Atom PDF