Project

General

Profile

Actions

Bug #8959

closed

Restoring a <2.4.4 config with legacy gold auto backup package re-adds the menu option under Diagnostics

Added by Matthew Drury about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
09/26/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.4
Affected Architecture:

Description

I was forced to do a fresh install of 2.4.4 as updating packages before the base OS broke my system. After a fresh install of 2.4.4 and uploading a config of 2.4.3_p1 the AutoBackup from the legacy gold system was attempted to reinstall and re-added the menu option for the AutoBackup under the Diagnostics top-down menu. If I click on the old menu option, I get a 404 Not Found nginx error. This option should be removed and pfsense should not re-add the menu if a previous config has the old package contained in the settings.

Actions #1

Updated by Steve Beaver about 3 years ago

  • Assignee set to Steve Beaver
  • Target version changed from 2.4.4-GS to 2.4.4-p1
Actions #2

Updated by Steve Beaver about 3 years ago

  • Status changed from New to Feedback

Diagnostics->AutoConfigBackup menu item suppressed

Actions #3

Updated by Steve Beaver about 3 years ago

  • % Done changed from 0 to 100
Actions #4

Updated by Anonymous about 3 years ago

  • Status changed from Feedback to Resolved

On 2.4.5.a.20181012.2248, restoring a config with AutoConfigBackup installed does not result in a system with Diagnostics > AutoConfigBackup as a menu item.

Actions

Also available in: Atom PDF