Project

General

Profile

Bug #8991

Codel limiter generating error in system log and console

Added by Max N about 1 year ago. Updated 3 months ago.

Status:
Not a Bug
Priority:
Very Low
Assignee:
-
Category:
Traffic Shaper (ALTQ)
Target version:
-
Start date:
10/02/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:

Description

After configuring Codel limiters like shown on the Netgate YouTube video for 2.4.4 I noticed this message constantly showing up in the system logs:

config_aqm Unable to configure flowset, flowset busy!

The message is always generated twice at 00,15, 30 and 45 minutes every hour. It seems to match the recurring cron execution of /etc/rc.filter_configure_sync.

History

#1 Updated by Jim Pingle about 1 year ago

  • Priority changed from Normal to Very Low

If you read through https://forum.netgate.com/topic/112527/playing-with-fq_codel-in-2-4/ that appears to be harmless. There are workarounds on the thread, but it doesn't appear to be hurting anything.

There may be a way to squelch the log spam but it's not a priority.

#2 Updated by Paul K 10 months ago

Per below two forum posts by dummynet creator configuring Codel AQM and fq_codel scheduler, as shown in Youtube video, does not really make sense.

The correct configuration should have AQM set to Tail Drop on both, limiter (pipe) and child queue and scheduler set to fq_codel on limiter (pipe).
Once AQM is set to Tail Drop message "config_aqm Unable to configure flowset, flowset busy!" will not be generated.

https://forum.netgate.com/post/803468
https://forum.netgate.com/post/803139

#3 Updated by Jim Pingle 3 months ago

  • Category set to Traffic Shaper (ALTQ)
  • Status changed from New to Not a Bug

Follow the advice on the previous comment to avoid the errors.

Also available in: Atom PDF