Project

General

Profile

Bug #9071

Package restore after fresh install can fail, claiming packages do not exist

Added by Jim Pingle 8 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Category:
Package System
Target version:
Start date:
10/26/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:
All

Description

Tested on a fresh SG-1000 and SG-3100 after a recovery install and then config restore. In both cases, no packages were restored. Instead, the GUI showed the following notices:

Package acme does not exist in current pfSense version and it has been removed. @ 2018-10-26 09:24:13
Package nmap does not exist in current pfSense version and it has been removed. @ 2018-10-26 09:24:14
Package sudo does not exist in current pfSense version and it has been removed. @ 2018-10-26 09:24:15
Package System_Patches does not exist in current pfSense version and it has been removed. @ 2018-10-26 09:24:16
Package Shellcmd does not exist in current pfSense version and it has been removed. @ 2018-10-26 09:24:17
Package openvpn-client-export does not exist in current pfSense version and it has been removed. @ 2018-10-26 09:24:18
Package reinstall process finished successfully @ 2018-10-26 09:24:22

At which point I could go to System > Packages, Available Packages tab and see them all and install them manually.

It seems to happen only if the firewall doesn't get a chance to check for updates or otherwise fetch the package metadata before restoring. I tried again and made sure to let it check for updates before restore and then it did work. Seems like something that routine should be doing on its own, however.

Could be another race similar to #9045

Associated revisions

Revision 4be5ed9f (diff)
Added by Renato Botelho 7 months ago

Fix #9071: Make sure pkg metadata is updated when repo config changes

Revision db8a42e5 (diff)
Added by Renato Botelho 7 months ago

Fix #9071: Make sure pkg metadata is updated when repo config changes

History

#1 Updated by Steve Beaver 8 months ago

  • Assignee set to Renato Botelho

#2 Updated by Renato Botelho 8 months ago

  • Status changed from New to In Progress

#3 Updated by Renato Botelho 7 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100

#4 Updated by Danilo Zrenjanin 7 months ago

I did a fresh 2.4.4 recovery install on SG-3100. After restoring config file with installed packages all worked as expected with or without the internet connection. Can you please write more details on how to replicate this bug?

#5 Updated by Jim Pingle 7 months ago

Nothing special about the setup. The packages are listed in the output in the problem description.

In this case it's important that you not let it fetch the pkg metadata after restore, but it should have Internet access.

So after recovery, go to the GUI and do NOT complete the wizard, exit out of there and go straight to the Backup/Restore page. Don't stop on the dashboard or it might check for updates and not trigger this issue.

#6 Updated by James Dekker 7 months ago

Cannot reproduce on oldest or newest available 2.4.x snapshots. Looks like the issue is no longer present.

#7 Updated by Renato Botelho 7 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF