Project

General

Profile

Actions

Bug #9133

closed

"Show all configured leases" does not stay set after deleting a lease

Added by Daryl Morse about 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Low
Category:
DHCP (IPv4)
Target version:
Start date:
11/17/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

If you select "Show all configured leases", the setting returns to "Show active and static leases only" if you delete a lease. If you want to delete all expired leases, you have to reselect "Show all configured leases" for every expired lease that you want to delete. It did not always work this way. Please return it to the way it was.

It would be a big improvement if multiple leases could be selected and deleted at once.

It would also be a nice if there was a way to renew leases or ping the hosts.

Actions #1

Updated by Jim Pingle over 2 years ago

  • Category set to DHCP (IPv4)
Actions #2

Updated by Jim Pingle over 2 years ago

  • Subject changed from Suggestions for Status / DHCP Leases and Status / DHCPv6 Leases to "Show all configured leases" does not stay set after deleting a lease
  • Target version set to 2.5.0
Actions #3

Updated by Jim Pingle over 2 years ago

  • Status changed from New to Pull Request Review
Actions #4

Updated by Renato Botelho about 2 years ago

  • Tracker changed from Feature to Bug
  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • % Done changed from 0 to 100
  • Affected Version set to All

PR has been merged. Thanks!

Actions #5

Updated by Jim Pingle about 2 years ago

  • Target version changed from 2.5.0 to 2.4.5
Actions #6

Updated by Jim Pingle almost 2 years ago

The commit for this wasn't cherry-picked to RELENG_2_4_5. I just picked it back.

I applied the change manually and it worked as intended, but still needs to be tested in snapshots once it is available.

Actions #7

Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to Resolved

Works as expected on 2.4.5.a.20191217.2126

Actions

Also available in: Atom PDF