Project

General

Profile

Bug #9151

Console menu entry (14 SSH) is not updated properly after performing actions

Added by Constantine Kormashev 4 months ago. Updated 4 months ago.

Status:
Not a Bug
Priority:
Very Low
Assignee:
-
Category:
Console Menu
Target version:
-
Start date:
11/26/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

If SSH is disabled from menu, the menu might entry still show Disable Secure Shell. And vice versa if SSH is enabled from menu, the menu might entry still show Enable Secure Shell.

 0) Logout (SSH only)                  9) pfTop
 1) Assign Interfaces                 10) Filter Logs
 2) Set interface(s) IP address       11) Restart webConfigurator
 3) Reset webConfigurator password    12) PHP shell + pfSense tools
 4) Reset to factory defaults         13) Update from console
 5) Reboot system                     14) Enable Secure Shell (sshd)
 6) Halt system                       15) Restore recent configuration
 7) Ping host                         16) Restart PHP-FPM
 8) Shell

Enter an option: 14

SSHD is currently disabled.  Would you like to enable? [y/n]? y

Writing configuration... done.

Enabling SSHD...
Reloading firewall rules. done.

 0) Logout (SSH only)                  9) pfTop
 1) Assign Interfaces                 10) Filter Logs
 2) Set interface(s) IP address       11) Restart webConfigurator
 3) Reset webConfigurator password    12) PHP shell + pfSense tools
 4) Reset to factory defaults         13) Update from console
 5) Reboot system                     14) Enable Secure Shell (sshd)
 6) Halt system                       15) Restore recent configuration
 7) Ping host                         16) Restart PHP-FPM
 8) Shell

Here it shows Enable Secure Shell instead Disable Secure Shell. But sometimes it works without the issue

History

#1 Updated by Renato Botelho 4 months ago

  • Status changed from New to Not a Bug

IT happens because menu will only change after SSHd is really configured and running and it takes some time depending of the machine it's running in. If you wait few seconds and press enter to redraw menu it's going to reflect the reality.

#2 Updated by Constantine Kormashev 4 months ago

Maybe it would be better to update status immediately after changing, redraw menu with state what would be the result of the performed action, because from user point of view it might look like executed command was not applied.

Also available in: Atom PDF