Project

General

Profile

Bug #9448

Dynamic DNS options showing in GUI for IPv6 when not in use

Added by Matthew Drury 12 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
DHCP (IPv6)
Target version:
Start date:
04/02/2019
Due date:
% Done:

100%

Estimated time:
Affected Version:
Affected Architecture:

Description

This bug is basically an IPv6 version of a similar bug that was fixed previously. (Bug #8469) When loading the DHCPv6 Server page in WebConfigurator, it expands the Dynamic DNS settings even if none are being used at the time. I'm not sure if the cause is the same as the IPv4 bug #8469, but the effect is the same.

Selection_181.jpg (213 KB) Selection_181.jpg Jim Pingle, 10/21/2019 03:30 PM

Associated revisions

Revision 7ba6788b (diff)
Added by Jim Pingle 7 months ago

Apply the same fix from issue #8469 to DHCPv6. Fixes #9448

Revision 504ed861 (diff)
Added by Jim Pingle 7 months ago

Apply the same fix from issue #8469 to DHCPv6. Fixes #9448

(cherry picked from commit 7ba6788b155b92ad8c488c2891c9fe2601fe5c14)

History

#1 Updated by Matthew Drury 12 months ago

Forgot to add, this is present in 2.4.4_2

#2 Updated by Jim Pingle 7 months ago

  • Assignee set to Jim Pingle
  • Target version set to 2.5.0

#3 Updated by Jim Pingle 7 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#4 Updated by Viktor Gurov 6 months ago

Jim Pingle wrote:

Applied in changeset 7ba6788b155b92ad8c488c2891c9fe2601fe5c14.

Tested on 2.5.0.a.20191011.1853

Dynamic DNS settings is not expanded now, it's ok

But if you select non-HMAC-MD5 algo and press save, the Dynamic DNS button disappears:
https://youtu.be/uts1SInoLuQ

#5 Updated by Jim Pingle 6 months ago

  • Status changed from Feedback to In Progress

#6 Updated by Jim Pingle 5 months ago

  • Status changed from In Progress to Feedback

I can't reproduce that problem on a current snapshot. It's possible another change affected the behavior, such as the jQuery upgrade. Try it again, please.

#7 Updated by Jim Pingle 5 months ago

Actually, it is there even in your video. You scrolled by it. With a non-default algorithm, there are custom settings, so that section is expanded by default to display the custom option(s). See attached.

#8 Updated by Jim Pingle 4 months ago

  • Target version changed from 2.5.0 to 2.4.5

#9 Updated by Jim Pingle 4 months ago

  • Status changed from Resolved to Feedback

Needs checked and/or tested again on 2.4.5 snapshots

#10 Updated by Jim Pingle 3 months ago

  • Status changed from Feedback to Resolved

When saving on services_dhcpv6.php without any DDNS options entered, the section stays collapsed as expected now.

2.4.5.a.20191217.0637

Also available in: Atom PDF