Project

General

Profile

Actions

Bug #9540

closed

PHP Uncaught Error in Status/System Logs/Firewall/Dynamic View

Added by Jay Simons over 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
05/20/2019
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

I clicked the wrench in the upper-right corner to change the display to reverse order (newest first) and I got this fatal PHP error:

Fatal error: Uncaught Error: Cannot use string offset as an array in /usr/local/www/status_logs_common.inc:664 Stack trace: #0 /usr/local/www/status_logs_filter_dynamic.php(75): manage_log_code() #1 {main} thrown in /usr/local/www/status_logs_common.inc on line 664 PHP ERROR: Type: 1, File: /usr/local/www/status_logs_common.inc, Line: 664, Message: Uncaught Error: Cannot use string offset as an array in /usr/local/www/status_logs_common.inc:664 Stack trace: #0 /usr/local/www/status_logs_filter_dynamic.php(75): manage_log_code() #1 {main} thrown
Actions #1

Updated by Jim Pingle over 2 years ago

  • Category set to Web Interface
  • Assignee set to Jim Pingle
  • Priority changed from High to Normal
  • Target version set to 2.5.0

I can't reproduce this on 2.5.0 or 2.4.4-p3. I can change the setting every which way, no errors. That said, I can sort of see how it could happen, and I will commit a change which may help in case it still happens in an edge case I can't reproduce here.

Actions #2

Updated by Jim Pingle over 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #3

Updated by Jim Pingle over 2 years ago

  • Status changed from Feedback to Resolved
Actions #4

Updated by Jim Pingle almost 2 years ago

  • Target version changed from 2.5.0 to 2.4.5
Actions #5

Updated by Jim Pingle almost 2 years ago

  • Status changed from Resolved to Feedback

Needs checked and/or tested again on 2.4.5 snapshots

Actions #6

Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to Resolved

Looks good on 2.4.5.a.20191217.0637

Actions

Also available in: Atom PDF