Project

General

Profile

Bug #9795

FRR add two or more ipv6 BGP Neighbors will system down

Added by yon Liu 2 months ago. Updated 18 days ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
09/26/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.5.x
Affected Architecture:

Description

I found that the problem recurred,If I add two or more ipv6 BGP Neighbors, the Remote AS is the same ASN number. like 39751. Then the system will crash or it will automatically revert to a bgp neighbor configuration.

I have installed a new version of the pf system, but the frr installation package is the same. I am also a new configuration frr, so there is no problem with my configuration is incorrect. So I am sure there is a problem with the frr installation package.

problem with any pfsense system version or new configuration.

https://forum.netgate.com/topic/146520/pf-2-5-crash-report-details/4

20190925.txt (306 KB) 20190925.txt report yon Liu, 09/26/2019 12:08 AM
20190926.txt (153 KB) 20190926.txt yon Liu, 09/26/2019 12:08 AM

History

#1 Updated by Jim Pingle 2 months ago

  • Status changed from New to Not a Bug
  • Priority changed from Very High to Normal

In my lab, I have two interconnected instances of FRR with the same ASN on two neighbor entries and it's stable. It's been setup that way for a year or more. Thus, I cannot reproduce this crash as stated. There is something specific to your environment or deeper in your config going on here. Keep the discussion on the forum until a root cause is identified or there is additional confirmation.

#2 Updated by yon Liu about 1 month ago

i test find this frr with openvpn happen issue, when frr use two ipv6 BGP Neighbors, then the issue will happen.

#3 Updated by yon Liu 18 days ago

i try setup use openbgpd normarl work ipv6 with openvpn. so i think the frr sure has bugs.

Also available in: Atom PDF