Project

General

Profile

Actions

Bug #9946

closed

package install failed: unset the 'vital' flag with: pkg set -v 0 pfSense

Added by Viktor Gurov almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Category:
Package System
Target version:
Start date:
12/05/2019
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.5
Affected Architecture:

Description

...
[14/17] Fetching talloc-2.1.13.txz: ...... done
[15/17] Fetching postgresql95-client-9.5.13.txz: .......... done
[16/17] Fetching mysql56-client-5.6.41.txz: .......... done
[17/17] Fetching gdbm-1.13_1.txz: .......... done
Checking integrity... done (0 conflicting)
pkg-static: Cannot delete vital package: pfSense!
pkg-static: If you are sure you want to remove pfSense, 
pkg-static: unset the 'vital' flag with: pkg set -v 0 pfSense
Failed

2.4.5-DEVELOPMENT (amd64)
built on Thu Dec 05 09:18:03 EST 2019
FreeBSD 11.3-STABLE
+ ZFS

clean install on QEMU (GNS3)

Actions #1

Updated by Viktor Gurov almost 2 years ago

  • Assignee set to Steve Beaver
Actions #2

Updated by Viktor Gurov almost 2 years ago

  • Assignee changed from Steve Beaver to Renato Botelho
Actions #3

Updated by Viktor Gurov almost 2 years ago

  • Subject changed from freeradius package install failed to package install failed: unset the 'vital' flag with: pkg set -v 0 pfSense
  • Category deleted (FreeRADIUS)

FreeRADIUS
zabbix-proxy
avahi
frr
pfBlockerNG
pfBlockerNG-devel
suricata
snort

...need to test all packages

Actions #4

Updated by Renato Botelho almost 2 years ago

  • Project changed from pfSense Packages to pfSense
  • Category set to Package System
  • Status changed from New to Feedback
  • Target version set to 2.4.5

It was caused because image was pointing to 2.4.4 repository by default.

I pushed a fix and it will be available on next round of snapshots.

Actions #5

Updated by Anonymous almost 2 years ago

  • Status changed from Feedback to Resolved

tested on 2.4.5 gitsync'd to RELENG_2_4_5, worked as expected, packages mentioned above installed without issue. (mistake on my end, error is still present)

putting back to Feedback for now.

Actions #6

Updated by Anonymous almost 2 years ago

  • Status changed from Resolved to Feedback

(mistake on my end, error is still present)

putting back to Feedback for now.

Actions #7

Updated by Anonymous almost 2 years ago

With the proper test repo pointing at 2.4.5, the packages install successfully.

Actions #8

Updated by Renato Botelho almost 2 years ago

James Dekker wrote:

With the proper test repo pointing at 2.4.5, the packages install successfully.

gitsync is not enough, pfSense-repo must be updated to latest version and proper branch selected on System -> Updates -> Settings

Actions #9

Updated by Anonymous almost 2 years ago

  • Status changed from Feedback to Resolved

Right, it works now.

Actions #10

Updated by James no over 1 year ago

Hi
I was on 2.4.4 and tried to install suricata just now, and got an error "pkg-static: Cannot delete vital package: pfSense!".
Upgrading to 2.4.5 has fixed the problem
Thanks

Actions

Also available in: Atom PDF